relative snapping for Midi note length

Hi everyone. I dunno how this happened but since recently the way cubase resizes my midi notes has changed. When the beginning of a note is not on the grid, the note is not automatically resized to fit the grid, but depending on the note length.
Let’s say I have a 8th note at 1. 1. 4. 46. When I try to make the note longer by resizing it, it automatically makes it end at 1. 2. 3. 46, so that the note length is exactly 0. 0. 3. 0. I would prefer thatit resizes it to make it fit the grid, so that the end of the note is 1. 2. 3. 0.
Thanks!

Have you changed the Snap from “Grid” to “Grid Relative”?

Yeah. It changed the way the notes are placed when moved, not when resized.

How to do that?

@lucas_marchal what are you talking about is not Cubase default behavior, my instance works as you want, if note isn’t quantized and u resize it, it still snaps to the grid.

I have just noticed that I have the same BUG! And it’s literally bug cuz I don’t see any difference between Grid and Relative Grid Snap!

And it’s totally not how it used to be in Cubase 5 from what I have just upgraded!

Yeah I must have involuntarily used a shortcut to change the default behaviour. It happen to me quite often, but I usually know how to revert to default settings.

Y’know, it does seem wrong. Dragging Lengths in the Project view follows the grid absolutely or relatively depending on the grid or grid relative setting, respectively.

Where is that Grid Relative setting? I can’t see it anywhere in the key editor.

I have just checked C5, it works the same as C9. It means I didn’t need it much if I didn’t know it :smiley:

I guess the only working out is to edit Information bar.

My mistake… apologies… I really was under the impression that “regular” Snap to Grid (i.e. not “Grid Relative”) would do just that, but, as we have now noticed the lengths are always absolute.
Best I can suggest is to let it happen anyways, then use the Scissors tool to split the note at the grid line (then delete the remnant).

Hm… I would like that to work the same way in the Project page as in the Key editor… but it doesn’t.

The Length commands in the quantize section do take care of it too, though.

I’m glad it wasn’t just me noticing this. I just upgraded to Nuendo 8 from Cubase 9, and it does this too. I just created a post in that forum:
https://www.steinberg.net/forums/viewtopic.php?f=275&t=121568 My issue was that it seems to only affect the end of midi notes. I can’t snap the end to the grid, if the beginning of the note is off the grid. For example if it starts a bit early before the beat, and ends a bit late. Dragging the end will not snap to the grid lines. It remains relative in length from the start of the note. My video shows the behavior: https://youtu.be/KsHkHHDf8DE I don’t remember this ever being the case in earlier versions. My work around is to clean up the front of the note first, then trim the back, but if I want a little looseness to the midi it becomes a pain with snap on. Best to just eyeball it with snap off for now. I hope Steinberg fixes this soon.

Edit: I see soundpeaks_net tried this out with v5 and had same issue. It is still annoying though, even if we’ve lived with it this long.