Remote control with DM2000

We have a DM 2000 connected to the studio computer. In WL6, I was using the transport control section on the console to operate the transport functions in WL, as I do with Nuendo 4 and Cubase 6. In WL7, I try to assign MIDI controller information for the DM, but it keeps telling me that the MIDI command is already in use and won’t let me add it (play, stop, FF etc…). Anyone else have this problem?

Yes, I have the same problem with the O2R96V2. But I have no solution…

EK Sound, are you using WaveLab 7.01? What commands do you use for instance?

Hi Philippe,

Tried both V7 and 7.01 (Win7). In version 6 I was easily able to add the transport panel on the DM2K to control stop, play, ffw, rew etc. I could do this by opening the “customize commands” editor and clicking on the MIDI event area. I could then press “play” for instance on the DM and the command string would be entered into the field. The problem is that WL7 comes up with the same MIDI command string for all button presses on the DM… then warns me that the command has already been used in another location. I have attached a screen shot for clarity.
WL7.jpg
Thanks!

I will have to check with Control changes. But in the mean time, can you try to use MIDI notes instead?

I also saw, that in WL7 all key-codes of the mixer are displayed as the same. When I e.g. press “stop” at the mixer (O2R96V2) and then “start” WL7 displays the same codes. WL6 displayed different codes.

What are meant to be the exact MIDI key codes for these start and stop?

WL says that all keys send “Control Change 15 Wert: 14 Kanal: 1” (sorry I have the german version). It doesn’t matter what key I press, WL says with all keys (play, stop, ff, rew, rec). But I think it sends MMC (Midi Machine Control) commands.

I see, WaveLab currently does not support MMC. You need to send classical midi event, no sysex.

WL6 supported MMC?

No, WL6 did not support MMC.
If you have the 2 applications open, I really doubt you see different MIDI commands in the dialog. Else show me screenshots :wink:

Ok I will do it today, but to make this possible I have to install WL6 in the same machine. Is this possible? But the Dialog in WL7 just posted by EK Sound in this thread.

I’m sorry, but it isn’t possible to install WL6 on my machine. The installer of WL6 always say I have to terminate the programs which are using the e-licenser. But I have no one running. Because of this I cannot install WL6. So I cannot show you screenshots.

Ok, now with an uninstall of the e-licenser the install of WL6 was possible.
Here are the screen captures of the commands in WL6:
Stop.jpg
Rec.jpg
Play.jpg

And here the last two:
Rew.jpg
FF.jpg
As you see in WL6 each key has a different value while in WL7 each key has the same value…

Are there any news about this error?

Using WaveLab 7.01, I have no problem entering a Control Change command, and use it as a trigger. See picture.

To know what really come out of your MIDI controller, you could use this tool:
http://www.midiox.com
22-02-2011 11-20-40.png

Thank you.
But the problem is, that WL7 receives other data than WL6 and all data that WL7 receives are the same. I do not think that the mixer sends wrong data because it worked fine with WL6. But I will check it with midiox.

Hello,
I attached what the mixer sends.
midi.txt (1.75 KB)

You should get a single event, and you get 4. This is not normal. WaveLab expects a single event.