Remote Desktop ASIO driver no sound issues

Recently I wanted to upgrade my mobile set-up to a more portable version. Untill now I carried a round a heavy, but capable laptop.
However, it is necessary for my profession to have acces to Dorico when on the move. So I tried using the Chrome Remote Desktop app. Which worked great and is incredibly easy to set up (no need to mess arround with IP adresses) but as you guessed it… No sound in Dorico.
I’ve tried all possible audio settings without any succes.
However: I noticed that even though I had sound on my main system, windows mixer was not registering any of it. It has very likely something to do with the generic ASIO driver although I do not know what causes this behaviour (and would very much like to know so).
However: I found a workaround.
It involves installing VoiceMeeter, which is a free program.

  1. Install VM.
  2. Dorico device setup: choose Voice Meeter input as output device. Close dorico.
  3. Open Voicemeeter, set VB-Audio Voicemeeter as input device and your system speakers as output.
  4. Make sure windows is using the system speakers as audio output (yes, this is actually important).
  5. Start Dorico, if you have no sound -> reboot.
    That should do it!
    If you plan on using chrome remote desktop often I’d recommend keeping these settings. Otherwise it’s better not to use voicemeeter as it will always have to load after booting.

An other option to solve this would be using the ASIO 4 ALL Driver. I’ve used this in the passed to get sound to come through to my wireless bluetooth headphones. The generic ASIO driver was causing problems.
Paul Walmsly uses the windows ‘remote dekstop connection’ and has no sound issues. I’ve tried Teamviewer: the same issue occured for me.

Haven’t tried windows remote desktop myself though!

Try these two alternative drivers:
https://github.com/dechamps/FlexASIO
https://github.com/levmin/ASIO2WASAPI
Or FL Studio ASIO Driver (shipped by demo or retail version of latest FL Studio).