Remove All Flow Information

I’m not sure if I’m understanding this correctly. I’m writing a simple piece… no movements or anything; just one piece. Does the title go in the Project or in the Flow? I’ve put it in the Project, and I don’t want the flow information displayed at all.

In Layout Options, I can set Show Flow Headings to “Never,” which hides the flow heading only on the first page of the full score. It still displays on pages 2+ in the full score, and also on every part. Even if I blank out the flow title in Project Info, it still shows the number of the flow on parts. How do I completely get rid of this?

If I go to the Engrave section for a part, go to “Flow Headings” and delete “{@flowNumber@}. {@flowTitle@}” from it, it removes it, but it still leaves the little green box that makes room for it. This feels like the wrong way to do something that seems like it should be so simple. No flow titles. Ever. Is there a setting somewhere I’ve missed? Or am I thinking about it wrongly?

Welcome to the forum, aprilwine.

“Flow headings” are the titles you see above the first system of the flow, and turning them off in Layout Options disables those, but the running header you see on subsequent pages is part of the ‘Default’ master page pair, which you can edit in Engrave mode: be sure to edit the master page in the right-hand panel rather than simply deleting the header text frame from each page.

So you do indeed want to set flow headings to ‘Never’ in Layout Options to prevent the frame etc. from being created on the first flow, but if you also want to remove the running headers on subsequent pages, you do that by editing the ‘Default’ master page pair.

Wouldn’t it be cool to have a default alternative master page in the templates without the flow header? I’d say in 90% of all written music there’s no second header needed. Personally, I wish I could switch all flow headers off in all templates at once.

Not that the flows and the headers are a bad thing. I think it’s a very clever idea! But it’s too complicated to remove when not needed.

You can select when to display the main headers and the flow headers, in Setup / Layout Options, Page Setup, Flows. You don’t need to change the templates.

…And set that as the default for all future projects.

Apart from Operas, Musicals, Film scores, Symphonies, instrumental suites, Song cycles, most Church music, anthologies and albums; yeah, probably 90%. :smiley:

But somebody can make 1000 lead sheets in the time it takes to publish one opera properly :imp:

This is the published part. I think most of the written music made with notation apps is for instrumental lessons, rehearsals, lead sheets, live bands… whatever. I don’t want to fight about that, it’s just my perspective as an arranger for mainly live performances and recordings (no print publishing). I never needed more than one header in my world except for film scores.

Often it’s more important for me to get more music on fewer pages. As said, even when switching off Flow headers there’s unused space that has to be edited in the master page when starting with a template.
My ‘wish’ header for most project looks like this:

Intrument - TITLE - Comp. Mrs X, Arr: Mr Y (all in one line to save space)

Or am I wrong? Can I get rid of the flow header frames and save it for ever as default for all templates? As far as I understand I have to edit the master pages for score and parts for each template. (At this point a big thank you to @dankreider for the master page tutorial).


But I think it’s a temporary problem. As soon as Dorico offers the possibility to save templates anyone can build special templates and share them with other users.
And sorry if I make things too complicated here!

You can make up a a file that uses Master Pages you customize and than save it without flows to open and resave under a different file name for each composition you want to write.

Daniel has proposed this work-around to another user for a slightly different setup.
https://www.steinberg.net/forums/viewtopic.php?f=246&t=154332&p=828940&hilit=template#p828940

Yes. See what Rob and Dan wrote above.

Got it! Thanks a lot!

Thanks for all the information guys!

Useful thread. Nice I can easily switch off flow headings in the Lay-out options. I would suggest to have another option right there, to show flow headings, but without number. I’m sure I can get this done in another way (by manipulating master page or something), but that seems an obvious spot for it.

Justus, Edit the default Flow Heading. You’ll find it above the Master Pages in the right panel of Engrave mode.

Thanks Leo,
I actually tried to do this, and then couldn’t figure it out (because I was wrongly looking for it under Master Page), and then decide to sort it out later when I had more time to study the tutorials (there’s so many of those to go through!). Nevertheless, I think an option under Lay-out options seems an obvious addition. Anyway, it’s not a major issue (now that I know how to do it through the Flow Heading) :slight_smile:

Could I just check whether something I’ve done is the correct procedure? I’m trying to learn Dorico by starting with something basic like a solo piano piece - though I’ve only managed 60 bars so far in several months, as I do my best to master the concepts and commands - and I wanted to remove the part name from the head of each page. Help pages and forum advice mention editing headers, but does that include deleting them entirely, as I have done in my case to the green-framed text in Engrave mode, and - by so doing - the frame itself? This certainly seems to have worked, but should I have done it another way? (BTW, I’d already applied Show Flow Headings>Never in Layout Options.)

Deleting the green framed text is a perfectly sensible approach, but if you want this change to apply across multiple pages, you should perform the deletion on the master page, not on each individual page.

If you mean the thin text frame at the top of page 2 onwards, remove that by editing the Default master page in the Default Part master page set.

Thanks, pianoleo. The part number isn’t showing on any page now, so I seem to have done it right. [Edit - I cleared the below problem by closing and reopening the file, but I’ll keep the original text in case it’s relevant in any way.]

But now I have another problem, and it’s either something to do with the deletion process or a key-combination that I’ve inadvertently pressed, but I find I can’t select anything in Engrave mode except for the text frames. Write mode works as normal, but Engrave seems stuck. I can still move around the score with the hand tool, but not even the options on the left panel are selectable, so I can’t escape from Frames - it’s the only icon that responds to a mouseclick (by losing its blue colour when the mouse button is depressed); the others behave as though they are greyed out. Could you help me with this?

Are you definitely running Dorico 3.5.10, Gareth? The problem you describe can occur if you leave Engrave mode while the master page editor is open, but (so far as I remember) the issue is fixed in the 3.5.10 update. If you need the update, you can download it from here.