Remove all references to "Flow"?

Hello, just getting into Dorico 4, and loving it so far.

I was very excited to see the YouTube video where we were told we could use the new “Create New” functionality to UNTICK the box, “Project will use multiple flows” and then we wouldn’t see flow headings. This would be a HUGE help to me – I find the topic of flow headings confusing and I never seem to be able to get rid of them without going through multiple settings and options.

But when I create a new project in D4, and leave it unticked, I still see the dreaded “1. Flow 1” appear.

Is there a way I can tell Dorico 4 I want NO references to “flows” of any kind, in any part, on any page, in any way? I simply don’t use them often and had hoped this new change would fix that.

Grateful for the new program!

I suppose Layout options (select all layouts on the right panel)> Page Setup>Flows > Never show flow headings, apply and save as default should free you from these headings, even in Dorico 3.5…

1 Like

I found something strange with the templates I created. I tried several times (because I thought I was wrong) and it always happened. it happens that when the model is loaded the information of the flows / project header is displayed, after a couple of seconds it disappears

Thank you for your reply, Marc. So I did all that (and I’ve tried it before). Saved as Default, and just started a new test project in D4. Indeed there is no Flow heading, but on the second page of the score, I see the dreaded “Flow 1.”

I’d like to remove any and all references to “Flows.” Is there a way to do this?

Really appreciate your help, I’m obviously not getting something!

This requires an edit to the Master Page/Page Template. If you have Dorico Pro, you can edit it. Go to Engrave mode, under the Page Templates section of the right-hand panel, double click the Default template. There, you can edit out the Flow info and put what you want there.

1 Like

Steve, while I am sympathetic to your request on the one hand, on the other, you really need to come to grips with flows. Even if you don’t show flow headers and only ever have one flow per file, you are still in a flow. This is why the second page has “flow 1” in the header. As soon as you type in the name of your piece in the information dialogue, the title will populate there and “flow 1” won’t show anymore.

It is technically possible to only go off of the “project” info, so you could alter the default master page to say {@projecttitle@} but you’re really making a mountain out of a mole hill.

Actually an easier way. Open the project Info dialog and enter a <space> in the Flow Title field.

1 Like

I think part of the problem is that there’s nowhere I can see to do that in the initial set-up page at all (I gave the project a title, of course, and that appears on the first page. But the second page still says Flow 1). So giving it a title doesn’t cause any “re-populating” in that sense, at least as far as I can see.

I then went back into Project Info, and there my title is listed, but I finally realized I needed to highlight “1. Flow 1.” There I see a title bar that I can change (simply deleting it doesn’t do anything).

Trying to “come to grips” with it! It does seem a tad convoluted, but I think I’m getting it.

Your Project Title is independent of your Flow Title. That’s because the project may be called “The American Songbook,” and the first flow (that is, the first song of many) might be “Oh, Susanna.”

I can feel your pain here Steve - I’ve felt it myself! - it is a bit silly IMO - if you type a title into the new project dialogue and untick “uses multiple flows” then one of two things should happen -

flow 1’s title should be populated with the same info as the project title (more confusing) or

The “{@flowTitle@}” token in the default master page should be replaced with “{@projectTitle@}”

The fact that it doesn’t is highly confusing for users that don’t immediately tumble to what flows are, and inconvenient to users that do!

BUT

what about if you create an empty project, turn off the “show flow header” option in layout options, then edit the default Master Page, replacing “{@flowTitle@}” at the top with “ {@projectTitle@}” and then saving it as a custom template? Then at least you only need to enter the title in the project info box each time…

1 Like

(Should also point out that the reason those two tokens aren’t swapped is because as soon as you decide to have more than one “flow” then that same token becomes confusing again for the same reason, and easily overlooked. I agree with my fellow forum users here - understanding the concept of a flow is pretty crucial)

1 Like