Remove duplicate MIDI notes

I have a MIDI track that somehow has every note and controller event recorded twice. The “Delete Duplicate” function works on controllers, but not at all for notes. This situation has existed for many years, apparently.

As noted elsewhere, the feature, when implemented correctly, should also include a Window so that you can set duplicates within 1 or 2 ticks of note-on and note-off, for example.

After about 10 years of complaining, I finally got SB to accept it as a for realz bug a few months back.

So this is not really a ‘suggestion’ anymore.

When they’ll actually get round to fixing it is, however, anybody’s guess.

No excuse for this. That is just sloppy programming.

I haven’t seen this with USB MIDI controllers (yet), but seems common when using audio devices that have MIDI ports. Those MIDI ports sometimes have two drivers enabled in Cubuse; DirectMusic and Windows MIDI. Tracks that are set to “All MIDI” will see data from both drivers originating from the same physical port, and record double data simultaneously.

In the MIDI devices setup window, be sure every MIDI input is disabled except for devices you are expecting data from. Pay close attention to the “All MIDI” column and only have devices enabled that should be sending data into Cubase.

I don’t know the difference between the driver types, DirectMusic and Windows MIDI. I just pick one of them. :mrgreen:


I had the same problem - after spending ages messing around with MIDI port settings in Cubase, it turned out the controller keyboard was sending out the duplicate notes. It was in a ‘split’ mode designed for playing multiple sounds on the same key, but spitting the MIDI information out on the same channels - can be worth checking the settings on your controller keyboard.