Remove voice 2

I am editing a score, where 2 horns are notated in one staff, each on in its own voice. I now created a new player for horn 2 and moved voice 2 of the “2 horns” stave to the new staff via “ALT + M” and renamed the original staff to “horn 1”. Now in “horn 1” rests are shown, where horn 2 was.

Bildschirmfoto 2022-12-20 um 09.50.42

How can I get rid of these rests for the whole staff efficiently?
Is there a better method that moves notes into anther staff AND removes any “left overs” in the original staff?

Filter for everything in that down-stem voice and delete it all, then save, close and reopen the project; Dorico prunes empty voices on loading, so provided there really is nothing left in that voice, when you reopen the project, all traces of that voice will be gone.

1 Like

Thank you, @dspreadbury !

It seems that tuplets and stem directions will not be correct / yield a “confused” result:

Bildschirmfoto 2022-12-20 um 11.11.01

Am I missing something in my workflow?

What is wrong in this picture? It looks normal to me. Apart from the fact that the ones on top are slanted and the ones below aren’t, nothing looks “incorrect” properly speaking, and you have granular control over their appearance in engrave mode as well as each one individually via the properties panel.

Edit: stem directions; I see. Have you tried selecting these measures and “reset[ting] appearance”? Or just use F to flip the ones that you don’t like?

(My guess is you manually changed some of the tuplets when both voices were on the same stave and Dorico is remembering that. The ones in horn 2 are correct because that’s the new voice with no manipulation, whereas the horn 1 part is odd because that’s the part where things had been combined. There’s got to be some latent data hiding there. Hopefully resetting appearance will fix it.)

1 Like

@Romanos Thanks for your feedback!

Resetting manually of course fixes everything, but I was wondering if my workflow is missing something. The score comes from an XML import, so there were no manual changes of any kind on my part.

As for “what’s wrong”: not only the stem directions, but also the tuplets (currently they are bracketed on fully beams eight note groups [BTW: I should mention that the last examples are flutes])

I am also a bit confused that most of the items in the original staff remain with “forced positioning” turned on.

I looked at my XML import settings, and there many things like “Stem directions” and “Tuplet placement” are turned on. (Actually almost everything is turned on, just not the last 2 options.) Therefore my score behaves as it does.

Thank you all for your help!

I usually turn everything off, except for note durations and Text items. The more you turn on, the more ‘overrides’ there are, instead of using the defaults.

1 Like

As I mentioned before, Reset appearance (and position) will likely take care of these issues. This is always a good idea with XML imports because it allows Dorico to do what Dorico does best.

1 Like