Removing pickup bars

I always have a hard time adding, dealing with pickup bars. I currently have a pickup measure that I want to completely remove. I try selecting the beat, shift+b and do -1. Doesn’t remove. I tried -1q, doesn’t remove either.

All this does is keep the pickup bar but shift the music back a certain amount
The only way I could remove it was to remove the ,1 in the meter signpost but then it creates an incomplete bar down the line.

What do I do about this? I just want to remove the pickup bar and keep the rest as you see

Current State

Quickest way:

  1. Activate Insert mode
  2. Select the “Global Adjustment of Current Bar” scope
  3. Select the rest in the pick-up bar
  4. Press Delete (just your standard Backspace/Delete key)
2 Likes

I avoid Insert mode if at all possible, so in your case I would usually add a 4/4 to the first full bar, then in the pickup bar do Shift+B, -1 to erase it.

3 Likes

That did the trick, thank you Lillie!

I agree @FredGUnn , I’m terrified of the Insert mode

1 Like

I even disabled the shortcut for it so I can’t accidentally hit it! There’s nothing like trying to engage Force Duration with O, mishitting the key, and then catastrophically destroying your project while Insert is active, LOL!

1 Like

Yep! I set its key command to open the interval popover instead!

2 Likes

I have to agree with your solution, Lillie’s did not work for me, I still had a bar marked “0” - and as others here have noted, Insert mode can be a minefield…

1 Like