Removing rests at end of condensed staves

I am creating short music examples with Dorico 4.0 to illustrate a book chapter I am writing, and need them to be no more than three staves, and to finish with no barline in the final bar. I’ve got most of the way there: I can use condensed staves to get the music down to three staves, and I have removed the rests from the end of each part. But in the condensed staves, the rests reappear! And cannot be edited! Why do they exist on the condensed staves when they don’t exist in the individual parts?
Here’s the full score:
image
And here is the reduction:
Reduction

I realize this is very much not what you’re asking, but in these sorts of situations where it’s for examples in print, I find it universally more helpful to create a totally separate set of players so I have full control. “Paste into voice” makes short work of it.

You can find options for how to handle rests on condensed staves in Notation Options > Condensing.

True, but I couldn’t find anything there that would solve this issue.

Thanks, Dan – I think that’s probably what I have to do.

Ah right, you’re more concerned with the final, incomplete bar – what about making that bar actually shorter (e.g. by making it 2/4 with a hidden time signature) and change the final barline in this flow to be “none” rather than graphically removing rests, which won’t carry across to condensed staves?