Removing unwanted lyric extender lines

Getting the solfege into this project… Thanks, all!

Go to Engraving options -> Lyrics. In the middle of the page, you’ll find ‘Minimum length for extender lines’. Putting a high number should keep them away.

What about individual lines? Solfege is in one line of lyrics and the proper lyrics (with needed extenders) are in the other.

Open the properties panel in Engrave mode. Mark the lyrics, and put -50 in “Line End x”. You can do it with multiple syllables selected.

Lyric extender lines only appear with tied notes already tied when you input the text, or if you use the space bar to go to the next note. Untie every occurence where you do not want the line to appear, input your text and you will tie again after. Of course you should not use the space bar at all, you move to the next note when inputing your text with the right arrow.
Hope it helps.

Is there a way to batch remove all extender lines in Dorico 3.5? Or I still have to use workarounds like what addressed above by Andale?

No, these are still the only options.