Render in Place chops first note of MIDI Track Arpache SX Insert

In Cubase Pro 11 Render in Place chops the length of the first note in an arpeggio on a MIDI Instrument track. It barely sounds.

I’m running Cubase Pro 11 on a Windows 10 PC. The Instrument track uses HALion Sonic SE 3 (GM 002) Bright Acoustic Piano for the VST instrument.

The arpeggio insert is Arpache SX with the following settings:


Direction – Up/Down
One Shot Mode Step Size – 1/8
Transpose – OFF Length – 1/4
Repeats – 3 Max. Polyphone -All
Pitch Shift – 24 Sort by – Note Lowest
MIDI Thru Velocity – Via Input

The Render settings are Processing – Dry, Tail Mode – OFF, and Bit Depth – 32 bit float

To recreate this problem do the following:

Create a new project with HALion Sonic SE 3 (GM 002) Bright Acoustic Piano VST instrument from Media Tab. In the MIDI Instrument track select Inserts and add Arpache SX insert.

In the arpachesx window choose the settings described above.

Add a 4 bar chord progression with each chord held for 2 beats. In 4/4 time.

Under EDIT choose Render in Place with the settings described above.


Could you please provide a sample project?

Test Arpegio Error in Render in Place.cpr (285.6 KB)
This project was created to test the problem in a blank project. The project file is not in a separate folder on my CP. Does that matter?


I see, the problem is, the MIDI Part starts at the very beginning of the project. It’s recommended to keep 1 or 2 first bars empty.

It still doesn’t render correctly though, because of whatever reasons arpache sx always starts on the wrong note when doing render in place, somewhere something isn’t reset properly or note ordering gets confused up.

You can work around that if you put some dummy chord at the start of every event you want to render.
like this:
Test Arpegio Error in Render in Place.cpr (271.8 KB)

First chord is garbage, but your actual sequence should start with the bass note now. You can cut off the first chord afterwards, just leave enough space for clearing reverb or whatever might be going on. (it’s not pretty but it works).



Thank you I will do that.


1 Like