Render in place doesn't work with MIDI file

Hi,

I have few MIDI tracks that are routed to an external synth ( defined in Studio> Audio Connections). However, I cannot do render in place with the midi events in the tracks. I tried for audio tracks and it works.

I can freeze the VSTi, and none of the tracks are muted.

Please help.

Thank you very much in advance.

CS

Hi,

If you want to use Rnder In Place with HW synth, use External Instrument in the Audio Connections.

In fact I am using the External Instrument in the Audio Connections.

Hi,

What is the Render In Place settings?

Did you select the MIDI event before you triggered Render In Place?

Yes. Of course, I do select the MIDI event before you triggered Render In Place.

My Settings are:
Mode: As Separate Events
Processing: Channel Settings
Tail mode: off
Bit Depth 24 Float - as my project settings!

I just noticed if I want to mix down the MIDI files, I need to create a new stereo input in Studio Connection’s input and disable the input connections in HW Instrument, and route them in Studio Connection’s input. But still it doesn’t do RIP. At least I know my connections are working!

You have to select the instrument track to RIP not the midi track.

Hi,

There is no MIDI event on that track! I am using VSTi. I am routing 8 midi track to the VSTi’s output. As I said I can playback and mix down to audio without any issues!

Always realize this! You can only RIP the audio that is coming into the audio inputs you defined for this particular external instrument! So any audio feed handled by ‘direct monitoring’ internally by your interface can not be rendered in Cubase.
If you have 8 midi tracks playing to your external instrument you must make sure all these sounds/tracks are also routed to the inputs you defined as inputs for your external device.

Hello All,
I also had the same kind of question. How do you freeze or render midi tracks. My particular scenario is as follows.
I’m triggering a snare. I have all the hit points converted to a midi track. That midi track is feeding an audio track that has a trigger plugin inserted.
The freeze option does nothing. And when I try to render in place not happens. At the moment my only option is to export audio mix down.
In this clip he simply selects the “instrument” track get his RIP settings and away it goes. https://www.youtube.com/watch?v=oo--VgmLLFc
An similarly on this video as well. Neither of which demonstrate my scenario. Any one know if and how I can render midi tracks in place?
Thanks.

It seems at Steinberg ( and also in the video) a midi track falls into 3 cases: A track defined as

  1. Midi with track instrument
  2. Midi with rack instrument
  3. (pure) midi not routed to any of above; for instance the output is routed to a Port of an external synth.

In case 1, you can do render in place while in last two cases you have only the mix down option.

Please recall that in a rack instrument, the audio bus is separated from the midi track while in track instruments they are combined. So actually when we are rendering MIDI notes on the midi routed to a rack, there is no audio signal on that track. I guess, the programmers at Steinberg would be able to implement that so that we can render the rack tracks! I think that was their design choice. But maybe they can make it happen and remove all the confusions!

No confusion here. :slight_smile:

With an external MIDI module as an instrument it is easier to just record it than to try and render it in place. Also I render in place Rack Instruments often.All you need to do is select the MIDI track to render in place a Rack Instrument.

I have been dealing with this for a while, this topic helped me - so, I have a few hardware units that I just could not render in place as RACK instruments - and i have been rendering in place since the option was introduced. Being composer with large projects, this was a great feature - but for external synths I found myself in a pickle. Instead of rendering in real time, i would just get - no response from software.
Then i read Chikitin’s post and found myself ashamed - I am using Cubase since 1996 and I have let something like this go past me.
True, I have seen people rendering in place from RACK, but i think it was older version of Cubase, for me it didn’t work.
Once I used it as a TRACK vst instrument (ofc provided you connected external instruments connections and set up MIDI), render in place worked.
One note though, once I render in place, I cannot create new vst instrument with the same synth - i have to deactivate previous track. I guess it makes sense because of the inputs.
I strongly suggest using both methods, so MIDI+audio tracks AND vst instrument, because you might want different things and different flows. However, again, TRACK vst will be bounced instantly, RACK will not. TY @chikitin