Render in place - external instrument real-time dialog

Since I installed Cubase Pro 9.5 I no longer get the “external plugin is used. Rendering must be done in real-time” dialog box after choosing Render in place. This used to allow me to render in place an external instrument.
Now the only way to render is to Export Audio which is way more time consuming. I cant see anything in preferences to force render in place to real-time.

Any ideas or is this a 9.5 bug?



I cannot reproduce it here. It works as expected. The message appears and the rendering is done in the real time. Do you render the event or the track? I tried both.

Thanks for the reply. It works fine in Cubase 9 but the dialog fails to appear in 9.5. Neither track or event is rendered. Wonder if I can import the external instrument from Cubase 9? Im also able to freeze the external instrument which shows the track can be rendered.


I tested it with Cubase 9.5. Could you try in Safe Start Mode, please? Make sure you add the External Instrument in the Safe Start Mode.

Hi Martin, I’ve tried that also and now I cant even start an instance of the external instrument as a vst instrument. Ill uninstall and reinstall.


When you reinstall, you still get your old settings. To get the factory settings you have to trash the preferences.

Still no joy with adding the external instrument. I cant even start an instance of the external instrument in vst instruments.


Could you try in Safe Start mode, please?

Thanks, never realised there was a safe mode. Anyway it still doesn’t work. I’ve had a support request with Steinberg since feb 5th. Pretty poor support for the amount I’ve spent on Cubase. I’ve started using ABleton where I dont get this problem. Loving the workflow.

Ok, figured it out. AT some point I must have renamed the external instrument. ie from Roland SE-02 to SE-02 . Didnt realise I needed to go into plug in manager and add the new external synth to my plugin list. Thanks for your help