Render in place - external instrument real-time dialog

Repeating this question as I think this is a bug in Cubase 9.5.

When I try and render in place with an external instrument. I no longer get the dialog box that says, render in real time.
This means I cant render an external instrument unless I go to export audio and select that track.
In the export audio the dialog box comes up saying I need to render in real time as im using an external instrument.

  1. Is there a setting somewhere when setting up the external instrument that i’m missing (was fine in Cubase 9, same settings)?
  2. Is there a preference somewhere that forces render in place to render in real-time.(I’ve looked everywhere for this)?


There is no preferences like this.

Is your External Instrument setup correctly in the Audio Connections? Could you try in Safe Start Mode? What exactly happened? The dialog doesn’t appear, and then?

Hi Martin,

I’ve tried safe mode and there’s not much can go wrong I think with adding an external instrument. All settings are identical to cubase 9 which had no problem rendering the external instrument.

Spent the afternoon removing all traces of cubase from the registry and reinstalling and I still get the same problem. Absolutely zero help from Steinberg on this fault as I’ve had a support question in for over a month. I can freeze external instruments but catnt render in place so something is going wrong.

I still cannot reproduce this. I just see the message.
Screen Shot 2018-03-14 at 09.20.10.png
Screen Shot 2018-03-14 at 09.20.14.png

Not sure what to do next,. Looks like your on Mac though. I’m on PC. The plugin manager shows Only RT which suggests Cubase sees it as external instrument. When I freeze the external instrument I get the real time dialogue.
Plugin manager.jpg