Render In Place processes "compete signal path" in "channel settings"

After the update to Cubase 10 Render In Place seems to ignore the selection to process “compete signal path” or "channel settings"it always renders complete signal path.
whichever selection i make its always the same result. I’ve tried different material and the files always null themselves when i phase reverse.

This used to work fine in 9.5 is there a workaround for this, or is it a know bug?


Could you try in Cubase Safe Start Mode, please?

So I Just did try on Safe mode and the same thing happens.
I opened a vst,recorded a couple of bars, i then routed it to a buss with a distortion plugin enabled. When I click render in place with “channel settings” i get the distorted signal.

This seems to be a bug, anyone else found the same behavior?


Sorry for my delay.

Yes, I can confirm this. Reported to Steinberg (CAN-20238).


I was able to reproduce it, but I cannot reproduce it anymore now. Now I think, it’s maybe related to some preferences. Could you ZIP and attach your Cubase 10 preferences folder, please?

I’m having the same problem. Was there any fix for this?

It seems its still broken , It still renders the full group audio path when only channel settings is selected. It puzzles me that so few have been experiencing this…


I was able to reproduce it for a short time, but I’m sorry, I cannot reproduce it anymore.

So strange, this should either work or not at all. It does not crash , it just does the same thing . First option where it copies all vst’s etc works fine. But second and third option give me the same results (it even renders send fx on group buss) . I use this feature all the time and now seems entirely broken.
Defaults.rar (112 KB)


I’m sorry, I still can’t reproduce it with your Defaults.xml file. But I got an idea…

The Rendered file itself takes the Channel Settings only. But the routing of the source track is copied to the Rendered track. So the new Rendered track is routed over the Group too. So you can hear the Insert effect of the Group Channel too. Of course, you can route it directly to the Output.

Isn’t this the case?

Hey Martin,

Sure I can route it to the output and it works this way but
a) that defies the purpose having the channel, group and full path option in the first place
b) i have to disable every plugin in the master buss
c) if the masterbus is different than 0 db, it will mess with my gain staging
f) if i do it this way i can export and reimport the track directly without using the render feature at all.

All I’m saying is that this feature worked excellent in until 9.5 (and it still does as i have it installed) but its broken in current version, and it seems that its only my machine/setup?


I’m not sure we are talking about the same.

My experience is, once I select the “Channel Settings only” option, the rendered file is:

  • dry - without the effects on the Group and Out Channel
  • routed the same way as the source channel (so once playing it back, I hear exactly the same as I heard before the rendering).