"Render in Place" track names are wrong using "Complete Signal Path" setting

Steps to reproduce:

  1. Create a midi or audio track.
  2. Record something.
  3. Select “Render In Place” and choose “Complete Signal Path”.
  4. Execute.
  5. Observe that the rendered event is correctly named after the original track name, but the track it ends up on is named after output. Which will always be “Stereo Out”.

Expected behaviour: The track containing the rendered event should of course be named after the original track name, not the output.

“Custom name” doesn’t solve the issue as it would require separate (manual) settings for each rendertrack manually written in, which no one has time for.

Any workarounds are welcome.

2 Likes

This is driving me nuts! Seems like an obvious naming scheme. Should at least be a third option.

What worries me is there are lots of threads on this going back YEARS and still no resolution. What a time waster.