Render-in-Place with Multitimbral VSTi?

Of the few minutes I used Cubase 8 after buying it today, I have to say that I’m a little disappointed in the Render-in-Place feature. That was the main reason I bought the upgrade, too. Besides the few crashes I got with it, I don’t like how it won’t render mono tracks. I also don’t like how it’ll render ALL channels on a multitimbral VST. When I want to render one channel of MIDI, it’ll not only add the audio files for that, but it’ll also add blank audio files for every other audio channel in that VSTi that’s enabled. Does anyone know a workaround for this?

I see that I can just delete the tracks with the blank audio files, but this will get messy quickly, as well as time consuming, if I want to render several midi clips in a single track.

You can render one channel, or even one clip. Read up on the Render in Place setup.

Yeah, I just found a Steinberg web page that details that.

However, none of that is working for me. I’m using Kontakt 5 and all of the midi channels in use have their own audio channel. I’d think “Mix Down to One Track” would be my solution…however that option is greyed out for me.

Can anyone puhlease help me with this?

I don’t like how it won’t render mono tracks.

A mono/stereo option (or even better a “no change” option) would have been nice.
As a workaround if your tracks are routed to a mono bus they will produce a mono render. (I think I read no bus does the same)

Yeah, I’m doing the mono bus for my VSTi bass track. However, I’m hung up on the “Mixdown to one track” being greyed out for me.

Isn’t the ‘mix down to one track’ only for rendering multiple tracks to one stereo file? That might be why it’s greyed out, if you’ve only selected one track…

I found something strange with the Render-in-Place options

  1. Select multiple midi clips.
  2. Open Render Settings
  3. Select “Complete Signal Path”. “Mixdown to one file” is now available.
  4. Check “Mixdown to one file”
  5. Click Cancel
  6. Try to render ONE midi clip, it will render to one audio file, eventhough the option was greyed out (if went into the render settings on step 6)

Now, try to render the midi clip again, go to render settings and click on either “Dry” or “Channel Settings”. The check mark in the greyed out “Mixdown” option disappears and now it’s back to rendering multiple files.

It’s a good feature, but there’s just some obvious oversights that I hope get rectified in a future update (AN UPDATE THAT’S NOT CUBASE 9).

How about Cubase 10? :laughing: