Render Montage in WL9 numbered tracks

Hello,

I’m ready to render my Montage - I want to export all tracks to new folder with added prefix numbers from 01 - but it

returns them rendered in the wrong order. I have a preset in naming scheme - separator / space, counter start / 1.

In render dropdown I’m selecting ‘all selected clips’ / named file / to selected location.

Always returns wrong order.

Any ideas?

With thanks,

Mark

Attached is a picture of the settings I use to achieve what you are asking to do. I think you might want to choose the render source of “All Regions” and be sure the region is defined as “CD Tracks” instead of choosing “All Selected Clips”.

Also, here is a link to the actual preset file:
https://www.dropbox.com/s/l4st9cacz50rbcu/Numeric%20Prefix.dat?dl=0
Screen Shot 2016-04-22 at 6.45.59 AM.png

Yes Justin. This is working. Many thanks. (If I knew how to thank you on the thanking thingy here - I would?!)

I think this is a bug that should be fixed… If I choose to render “CD TRACKS” instead of “ALL SELECTED CLIPS”, then crossfades are all rendered… and that means some tracks render without complete fade-outs, or they begin with the end of the previous song.

I have a customer who has requested that the wav rendered files I send him do NOT reflect the CD crossfades… so how do I export them then? If I render selected clips, the crossfade issue is fixed, but as this thread states, the counter does not number them in the proper order… For now, I have no choice but to render using “ALL SELECTED CLIPS”, and to then go back and manually rename all of the files (about 50 files in this case).

What reason is there for the counter to number the clips in a different order than how they appear in the montage? It makes much more sense to number them according to the montage order.

In my experience, when a client wants standalone versions of songs that have been crossfaded for the CD/vinyl etc, I just make a Save As… of the final montage, and then manually remove any crossfades by dragging the clips away from each other and then render new versions.

It takes only a few seconds. I think there is even a way to arrange the clips using a special menu so you can do this to many clips in one command.

I could see a case for a way to render one clip at a time and ignoring any crossfaded clips but still doing all the plugins processing, and then adding the numeric prefix to the exported file name so they remain in order.

Thanks Justin - I’ll drag the tracks apart as you suggest for now (but there are issues with this - see below). I agree with what you’re saying that it may be nice to have an option for ignoring crossfaded sections when using EXPORT CD TRACKS (there are issues with this too though - see below)… STILL, what reason is there when using RENDER SELECTED CLIPS to not do them in order?

With EXPORT CD TRACKS – if you you slide the tracks apart, you will have added extra unnecessary silence at the end of every single rendered file - unless you line up the end marker with the end of the clip. If trying to do that, Wavelab does not snap markers to the end of the previous clip unless you drag the marker itself, and then the following clip doesn’t follow with the marker… so there’s really no great way to do this. I personally would rather just use RENDER SELECTED CLIPS to eliminate any unnecessary silence. The only way to have CD TRACK EXPORTS match the actual CD track exactly when crossfades are being used, is to allow the exports to cut off the end of the clip at the CD track end marker.

PG - I think we could use a fix for this… either:

  1. EXPORT SELECTED CLIPS can be used with a counter that is in the proper order of the montage
  2. EXPORT CD TRACKS has an option to export and ignore clips that may be crossfaded while exporting each clip… In this case, it may be necessary also to have an option to export all the way to the end of the “clip” rather than the CD track end marker… BUT, I think this #2 idea is could be bad because of the possible confusion here… At least with #1, there is less confusion.

FWIW, because of the confusion in this case, my client decided to allow the exports to just be identical to the CD tracks - so the crossfaded track will be cut off in the exported files, but at least they will match the CD exactly… c’est la vie. I guess that makes my life a little easier today, but I know this issue will come up again at some point.

-Todd

Hmm, never came across this. Is it not a case of defining the numbering to be with 2 or 3 digits beforehand? So you don’t end up with stuff like 1 - 11 - 12 etc 19 - 2 - 20 - etc? I’m not at my DAW so can’t check right now…

I’ve been doing the numbers using two digits (01, 02, 03, etc.). When using EXPORT CD TRACKS, the numbering scheme works perfectly. When using EXPORT SELECTED CLIPS, it does not - the numbers are all out of order.

EXPORT SELECTED CLIPS can be used with a counter that is in the proper order of the montage

In WaveLab 9.5.40, the selected clips will be rendered in their time line order, as your suggestion.

Many thanks PG!