Render Time

Hi,

I render 45 minutes of mix and stems almost every day and wait almost 2 hours. Pro-L2 without oversampling on the 4 stems. And Waves L2 on the Mixbus. NR and DeVerb on 4 - 6 tracks. A few compressors and EQ.

How long does it take you to render a similar project?

Might be easier to figure out what your problem is if you stated exactly what’s in your mix as well as exactly what your system specs are (put them in your sig for future reference).

I’ll render out a 45m show that’s 5.1 with a stereo downmix, stems for both, so about 16-18 files split between 2.0 and 5.1… rendered simultaneously and it takes maybe 5 minutes.

Computer specs in my sig.

1 Like

Hi,

I’m using Nuendo 12.0.70 on a MacBook Pro M1/MacOS 13.4.1. I render 1 stereo mix and 4 stereo stems. The project contains approximately 50 tracks.

I would start looking at your NR plugins. Most people use offline processing for NR as it is very power hungry.

2 Likes

Hi,

I turned off all inserts. Rendering time for a stereo downmix is ​​approximately 28 minutes. Then NR activated. The rendering time has not changed.

45 minutes of content with no plugins (inserts) should definitely not take 28 minutes on a good modern computer.

What’s your buffer size?
What’s the drive your project is on?
What does the Nuendo performance meter look like when you’re playing back in realtime?
If you have a CPU meter that the OS provides what does it look like when you’re playing back in realtime?

I do feel Nuendo’s rendering time is a bit slow, but yours seems like something is wrong.

In comparison,
I render a 3hr show mix every week and it takes 45-50mins.
Pro-L at 4x oversampling on the master.
Pro-MB, DSEQ, UADx 1073 and 176 on the main dialogue track.

I used to do noise correction in the session as well, but that took even longer. Now I just batch process in RX before the session and it only takes me 3-4 mins compared to the 30-40min additional rendering time.

And what are the computer specs?

MacBook M1 Pro, 32GB, 1TB, Apogee Quartet at 128 samples.
The project is located on the built-in hard drive. Performance meter shows about 40 - 50%. OS Meter shows about 60%. Nuendo is set to 64 bit editing precision.
ASIO -Guard is active. Multi-Processing is active.

Ok. Increase the buffer to like 512 or 1024 to see if that helps. I tried this on my previous setup and there was a pretty big difference. Obviously also your 64-bit precision is high, but if you want it you want it, so no sense in dropping that I suppose. You could also play with ASIO guard of course.

Only other thing I can think of being a problem is your drive. I’m assuming it’s not literally a hard drive, but a solid state drive. Either way I would definitely experiment with using one or more different drives. In other words read off of one and render onto another, or move both read/write off of the built-in drive.

1 Like

Did you really turn them off, or did you just bypass them?

You were right. I just bypassd them. When turned off the render time decreases to 6 Minutes.

2 Likes

Quite frankly that still sounds a bit long. I have another show that I do that has fewer tracks and few plugins (just brickwalls) and outputs to stereo mix and stems and is 45 minutes and it takes me about 1:30 minutes to export.

Again, I would try to increase the buffer before the export. If that doesn’t cut it down then try different drives. And if that doesn’t cut it down further then I guess that computer just doesn’t go faster than that.

As for plugins I suppose the best thing to do is to turn things on gradually to see where the biggest bottleneck is and then just think about how you can resolve it. Maybe pick a different plugin (if on a group) or render offline (if on a track).

Certainly I agree with you that render times are ‘too long’ for a modern computer.

+1 on increasing your buffer size. That was really the only thing that made a difference on my setup, which is similar, although I’m still on Monterey/MBP M1.

Temporarily increase the buffer size to the biggest you have. See what that does to the export time.

What DeVerb do you use? I use Acon Digitals DeVerberate. But not in real-time but offline. Real-time causes exactly what you describe. I also use a MBP M1 Pro.

I use Waves Clarity.
Increasing the buffer size helped a little bit.
I also noticed that after the update a function was activated that put the hard drive into sleep mode. The ridiculous long render times are gone now.