Rendered audio doesn't sound the same as real time preview!


So, I’ve been working with Wavelab since V3. I was on V7 for quite awhile and am now on 8.5.30 build 871. Windows 7 64 bit machine.

I’ve run into an issue that I can’t figure out or understand.

When I render a WAV file, it is slightly different than what I am hearing while working on it. It’s slightly distorted and has a slightly different sonic signature when comparing it to the real-time chain I am running it through which is 100% ITB. I’ve tried rendering at different bit rates, both with and without dither but each time, the rendered file is the same exact slightly degraded version of what I am hearing right before I render.

I’m monitoring both versions from the same exact outputs so all variables are the same. I “Bypass the master section on the resulting audio file” so that I can quickly switch back and forth to hear the difference.

Although it’s very slight, it’s enough that the rendered file is not usable. I don’t really want to have to resort to some hokey workaround and drop my levels just prior to rendering. I just want a rendered file that sounds identical to what I am hearing when I’m working on it.

Any ideas?

There are so many variables but one thing that comes to mind it to test that all your inserted plugins are actually getting rendered.

I know of a handful of plugins where the VST3 version is audible on playback but doesn’t actually get processed on the rendered file. In these cases the VST2 version usually renders successfully.

It’s a small chance but maybe one of the plugins in your chain isn’t actually getting rendered causing some different unpleasant rendered files compared to real-time playback. If you suspect it’s plugin, try rendering a test file with each plugin one at at time with some extremely noticeable settings to see if it’s really getting rendered.

Another interesting test would be to move all your plugins to clip and track plugins so that no plugins exist on the montage master or global master section, then load the rendered file on to a new audio track, make sure it’s perfectly in sync (down to the sample) with the existing audio file(s) in the montage, and invert the polarity of the rendered file.

See if the rendered audio file with inverted polarity nulls with the live playback in the montage or if you hear some difference.

Dude! That was it!

Slate Virtual Mix Rack wasn’t rendering, and as the first plug in the chain, I was using it to trim the initial level feeding the rest of the plugins. So by that plugin getting bypassed, it was feeding a level that was “slightly” too hot for the rest of the chain and the sonic signature that I had chosen for the console type (Type N for Neve) was missing in the render.

Thank you SO MUCH for taking the time to respond and help. I appreciate it!


No problem. I actually regularly check plugins after either the plugin, Wavelab, or OS gets upgraded because I’ve found a fair amount of VST3 plugins that don’t like to render in Wavelab. You might have better luck with the VST2 version of VMR for now.

Slate is aware of the issue because I’ve been working with their partner company Eiosis to get their AirEQ straightened out in Wavelab which has a lot of the same framework as the Slate stuff. So, hopefully once they get things figured out they can apply it to the entire Slate/Eiosis family of plugins. I don’t use VMR in Wavelab but I have tested it and from what I remember, the VST2 version renders correctly.

I had never used VST before using Wavelab…only RTAS/AAX and AU so I’m not sure if its VST itself that’s so problematic for plugin developers to get right, or if there is something special about Wavelab that developers overlook and don’t properly test for.

Either way, I’m trying to make any plugin developers with this problem aware of the issue and also trying to see if there is anything on the Wavelab side that can be changed so this isn’t such a common problem.

I think it’s partly because Wavelab does not have a huge user base like Pro Tools, Logic, or Cubase/Nuendo and that plugin developers assume that testing in Cubase/Nuendo is probably “good enough” for Wavelab which is clearly false.

Man, that’s a bummer! This is a new computer I just built and for every plugin I’ve been skipping the VST2 installations thinking that surely all the latest software will handle VST3. Plus I didn’t want to see 2 versions of the same plugin listed just for reasons of tidiness in the list, and to reduce the amount of data used on my SSD drive.

Looks like I’ll be spending some time reinstalling…

Thanks again for your help!!!

I know what you mean. I had originally hidden all VST2 plugins from the plugin list in Wavelab so it’s less of a mess to look at but I’ve had to unhide a few VST2 versions to use until the VST3 version is stable.

FabFilter, Waves, Brainworx/Plugin Allaince, and NUGEN all seem to be okay regarding VST3. UAD and Sonnox are of course VST2 only right now so that solves that.

I’ve been hearing a difference in the rendered file as well.
I tested all used plugins one by one and they all worked individually. But when I render the whole thing it doesn’t sound the same… (if it matter it sounds baser with less details up top and less separation)
Is it possible that once they’re all active the render doesn’t work properly?

I was hoping to switch from Protools to Wavelab for a project I’m working on but I think I’m gonna have to finish the job in protools unfortunately.

I’m using plugins from Softube, Plugin-Alliance, DMG audio, Leapwing and SIR audio tools on this project.