Rendered in place instrument track has click sounds in it that shouldn't be there

As you can see here I rendered down this Kontakt library and I have some artifacts that sound like two cut audio files connected without fades. But when I listen to the instrument track I don’t get them.

I also rendered it down as one event, it doesn’t change a thing. They appear whenever new notes are sung in this choir library.

I don’t know what to do. This library constantly has standing notes and keeps playing when I pause the project.

I would really like to know why it doesn’t sound the same when I render it down. Same routing, same processing, but it has these clicks that you get when a waveform is cut and there is no fade.

Thanks for any help on the matter. Cheers


Could you try to increase the Buffer Size (before the Render in Place has been triggered), please?

Is there a buffer size for render in place in particular that I missed? Because I use 1024 buffer size on my Fireface UCX RME interface. I would expect that to be sufficient.

Thank you for your help


No, there is not.

It depends on the project.

I would give it a try. Btw, how is your ASIO Guard Setup, please?

Thank you for the reply:

This should be the ASIO guard setup if I’m not mistaken.

Setting the buffer size to 2048 makes it impossible to play in notes live due to latency, 1024 is already very daunting compared to trying to use M/K. But I will check it out. It requires to restart the entire audio interface and I would need to also restart my speakers, which makes switching buffer size really annoying.

I’ll share this too, just in case.


Try to disable the ASIO-Guard, please. Just to test it, how does it work then.

Oh, really? That surprises me. I wouldn’t expect this. Do you have the latest driver installed, please?

Now it looks like this:

The render’s almost entirely silent for the exception of some pops and click sounds. Or in other words, completely unusable.

I listened to the file in the project folder, and it does actually have the sound, that also is shown in the wave form. But the file still contains the noisy artifacts.

I don’t understand it because I don’t have them when playing from the instrument track, and when I render the other processes can be paused and I have a 10900k so that shouldn’t be an issue.

I will reinstall the newest one cos I don’t remember when is the last time I updated them, but I already did so a while ago. I will see if it works then. Thanks for the suggestion.


Then try to enable ASIO-Guard again and set it to High, please.

Also make sure the instrument (plug-in) is up to date.

I have used RME interfaces for over a decade and have always been able to change both buffer size and sample rate at will and with ease.
You should be able to bring up the settings dialog and make any changes while Cubase is running. RME’s drivers integrate very well with Cubase and will reflect any changes made in the RME settings.