Rendering of Mono-files

Hallo,
hope everybody had some great Xmas days.

On topic:

I’ve lately processed (sucessfully) some noisy samples (Mono wave files) with the Sonnox DeClicker
(inserted in the effects rack of the master section in the audio edit view) inside WaveLab Elements 7.01

I called up the Render function and set Channels/Samplerate and Bit-depth in the Audioformat dialog to
the setting “same as source”.

After the rendering I was quite surprised to see that the new files were created as Stereo Wave files
(with the identical audio data on both channels) instead of the expected Mono Wave files.

I also gave a try to render a mono sample without any processing (no plugins inserted in the effects rack) -
with the same settings as before I now get a stereo file with the audio information on the left side.

I managed to create mono-files in the end by changing the setting for “channels” in the audioformat dialog
to “Left Channel”.

But shouldn’t it just work with the settings I set before ?
Is this a bug or by design ?

You should set “Match input stream” to have the same number of channels (1) as input.

In older WLab Versions, I press Strg (or Alt) and drag a wave region to empty space to change the channels, mono to stereo or stereo to mono. Is this function gone? No function here and no info in helpfile …

Sorry, it’s not clear to me (I’m using the german version of WaveLab 7 Elements).

OK, I’m sure you’re talking about the Audio File Format Dialog,
4th dropout menu from top - in german called “Kanäle” - channels -
(or maybe you’re talking about a complete different setting somewhere else ??)

I can choose here between: “Wie Eingangsquelle” (translated: “same as Inputsource”)
-which I used with the first try and expecting it would then create a Mono Wave File,
since the Source File is a Mono File.
Shouldn’t it work this way ?

and also
“Left channel”, “Right Channel”, “Mono Mix”, “Mono Mix -3dB”, “Mono Mix -6dB” and “Stereo” as further options.

Are you saying that I have to choose “Left Channel” as the setting ?
But then I don’t understand what the very first option “Wie Eingangsquelle” is all about.

Or is maybe something missing in the german version in regards to these settings ?

:confused:

I’ve downloaded the english version manuals for WL 6 and 7, but these don’t describe the audio file format dialog
in detail.

Thanks for the help, sorry for being a noob…

Hello,

In Elements 7.01, when I try to Render a Mono file with sonnox and choose “Match input stream” what I get is: a Mono file.
Same thing for “Process in Place”.
Progetto1.png

Thanks markino for the screenshot,
very helpful - well, that’s the setting I used, but I don’t get a Mono file.

As said, this is with the german version of WaveLab Elements 7.01

Seems this function is not working correctly here !

Hi Iosan,

i’m a little confused: can’t you change the language in Options>Global Preferences>General>Language?
i was not aware of a German version! I can change the language in german as well.

have you set “Type” correcly?

EDIT: does your Master section look like this?

Have you tried to set the MONO button?
Progetto2.jpg

Sure, you’re right - I forgot about the option to change the language…doh…

“Type” is set to Wave (Microsoft),
yes, the Master section looks like this

Still I get a Stereo file.

If I activate the Mono button (force mono) the resulting wave file will be mono -
this does work, but it looks like you haven’t activated it (judging by your screenshot),
and I don’t think it should be necessary to activate it.

Don’t know what’s wrong here…

You are right, I did not activate the Mono button because I obtain a mono file without activating it.

Great PG, where are you? Heeeelpppp :open_mouth:

@Bassman: this feature is still there, but you have to press Alt+Control.

@losan: I can’t reproduce this problem with WaveLab Elements 7.01, if you set the Render dialog as Marco. Yes, “Wie Eingangsquelle” (“same as Input source”) is the “translation” in german.

OK, since I know now that it should work the way I did expected it to work,
there has to be a reason why it doesn’t work on my system !

The good news is that I found a solution to my problem.

After some more experiments with different settings and also changing audio drivers
I finally decided to trash all preferences (I backed them up before)

-voila, now everything works the way as it should :slight_smile:

I may should mention that I’ve got that issue already with version 7.00 of WaveLab 7 Elements,
so maybe it is some holdover from this version in the preferences.
@PG: any idea which config file could caused the issue ?

Well, now I am gonna see, which preferences files from the backup I am going to re-import,
I don’t want to necessary start all over again…

Thanks for the help

I remember I corrected something about this for 7.01, but what pref file is concerned, I must say I don’t remember.
But I don’t think this is in the sub-folder called “Preferences” which contains many user defined settings (eg. shortcuts…)

Nevermind…

Everything’s back now (didn’t take that long…)

:sunglasses: