Renders taking 2 - 3x real-time length

Having done some more investigation on this, it’s not just the Render of multiple tracks with plugins on each track which is badly implemented: it’s also the playback.

It seems that when playing back, say 10 stereo tracks with plugin chains on all tracks, but only one stereo track has an active audio file, WL is still processing the plugins on all the other 9 tracks … even though there is no audio file being played on those. I came to this conclusion after adding a 10th track to WL and suddenly being completely unable to listen to any part of the montage without it glitching. Remove the plugins from that 10th track and all was OK again.

You could simply mute the tracks you don’t use, I guess.

As a workaround, sure, but don’t you think it makes no sense for WL to be using CPU for tracks that aren’t even playing a file ?

Having an empty track with cpu expensive plugins is a rare situation, I would say. Making WaveLab constantly watch if the track has been dropped a clip to activate or not the track plugins, is some kind of overhead.
AFAIK, this is the same in any DAW.

I thought some programs had switched over to doing that, but maybe I’m wrong.

I don’t think you’re wrong bob99 … For starters, Cubase has an option for VST3 plugins: “Suspend VST 3 plug-in processing when no audio signals are received”. I don’t know what it does with non-VST3, but I mostly use VST3 in WL and Cubase anyway.

There’s another program that has a playback setting called Run FX When Stopped, which if you uncheck that, it takes care of the playback glitching/dropout problem with any plugins, VST2 or VST3. I think most programs have probably come up with something in the recent past to address the case of many tracks with a theoretical staircase of clips, all tracks unmuted, and track fx chains on all tracks. Googling I see Logic and Pro Tools, and I’d be surprised if Sequoia didn’t do something about this.

There’s an old thread here somewhere about the difference (or non-difference, I can’t remember) between Cubase and Wavelab in this regard but I’d have to dig it up.

Not knowing anything about it really, I thought even track automation took care of this in some cases.

Sorry, I’m wrong about the “other program”. That setting only makes the problem disappear completely if there are no clips on the other tracks, or maybe a few clips on a few tracks. If there are clips on everything, it makes the problem “better”. But I think there are other tweaks in there that do more, but as always I might be wrong about that.

Richard, you’re right about the VST3 setting in Cubase. That works great, and does exactly what you want. I had no idea that’s how Cubase handled this. I really hope this is added to Wavelab, because it would take care of at least part of the load. It’s what I’ve always wondered how other programs could possibly handle many tracks with track fx in a mastering setup of this type.

Just wanted to +1 this feature request again. Suspending plugin processing when there is no signal present would give Wavelab users a whole other way to set up a mastering session if they wanted to, using Track FX chains exclusively, and more FX, on many Tracks for clips staggered or staircased in a montage.

Apparently the option for VST3 has been in Cubase (and Nuendo I believe) for many years and the option is on by default, if I’m not mistaken.

Logic and Pro Tools effectively do the same thing.

It just seems so much more efficient, and would allow many many more tracks and fx before processing limits are hit for playback, causing glitching or dropouts. Or dramatically slowing down certain renders with unnecessary processing.

Even if there are a mix of VST3 and VST used, it seems it would still help a lot.

I can’t believe this has still not been fixed. I have Audio Montages with 10 tracks that have plugins on each track and the only way I can listen to the montage is to solo each track. Such a workflow killer.

PG - are you going to be addressing this at all ?

If you have no plugin, rendering is very fast. IOW, the bottleneck is your plugins’s processing time. What WaveLab can do?

I don’t think you understand the problem. When I am listening to a stereo track in an Audio Montage that has, say, 10 stereo tracks, all of them with plugins on them, those tracks that have no audio playing on them should have their plugins ignored, just like Cubase, Logic, etc.

The bottleneck is Wavelab not the plugins !

I think you’re getting confused by the title of this thread. The issue I am referring to came up halfway through the thread, here:

those tracks that have no audio playing on them should have their plugins ignored, just like Cubase, Logic

This feature is on the plugin side. That is, if there is silence (no audio), WaveLab tells the plugins. Then that is the responsibility of the plugin to bypass its processing.
Not all plugin support this VST-3 only feature.

I’m very surprised to hear that Wavelab already suspends processing for VST3 plugins when there is no audio, because I only use VST3 plugins yet I have this problem on every single Audio Montage project.

I use Waves, DMG Audio and Plugin Alliance plugins. How can I tell which plugins do not support this feature ?

WaveLab does not suspend processing: it tells the plugins “you can suspend your processing”.
But WaveLab has no way to know if a plugin supports this instruction. WaveLab passes the instruction, but there is no feedback from the plugin.

Following is what I found from testing in Wavelab a while back. The function to suspend VST3 is probably not very effective if you use 3rd party plugins with the Steinberg programs, because very few of the plugin makers support it. Suspend VST3 plug-in processing - Cubase - Steinberg Forums

In Wavelab, these VST3 plugins suspend processing when no signal present:

These don’t:

I don’t know if this covers all plugins made by these plugin makers, but that’s what I found testing one plugin from each in Wavelab. So it’s certainly not a comprehensive test.

I think the suspend function is possibly more effective with 3rd party plugins in Logic and ProTools (not just VST3), not the Steinberg programs.
Logic disables plugins when there is no active region - JUCE . Thats just what I’ve heard though, don’t know it from fact or experience.

OK, thanks for that. And it confirms what I thought: if most plugins don’t support this VST3 feature it’s not really very useful.

PG - can’t Wavelab just suspend all plugins on any track that is not playing audio ? I mean why would the user even want plugins to be processing silence ? There’s no need for it.

However if you get different results in Wavelab and Cubase, using exactly the same files, plugins, plugin settings, number of tracks, and interface and buffer settings, that would be something to question. That’s what I was asking on the Cubase forum, but I don’t think anyone over there tested it in Cubase.

The difference in Logic vs Wavelab I could definitely see, but not Wavelab vs Cubase.