Repeat signs are being ignored

Repeat signs are being ignored in my project when in playback. I don’t have the option Repeats in my Playback options, so I cannot click on the Play repeats option. I am sure the playback sections are correct. How do I fix this?

You don’t have Playback options > Repeats section? I don’t think that’s possible. Either you don’t have playback options (SE, Elements) or you have them all… Or there’s something I have missed there
Playback options dialog

I have Dorico 4.2. This contains Playback Techniques. With the options:
(…) Rake, Release, Right (RH), (…). So, no repeat options. Dorico ignores repeat barlines. I don’t know how to fix this.

Dorico 4.2 (whatever version Pro, Elements or SE) will play repeats only if the repeat structure makes sense. Therefore, if repeats are not played, there must be a problem with the repeat structure (unless you are using D4.2 Pro and have disabled the option to play repeats).

I wrote a new, small project with only two repeat bars (|: and :|). But Dorico Elements 4.2 ignores them. An existing project runs fine under Dorico Elements 3.5, but not under Dorico 4.2. I cannot believe Dorico 4.2 cannot repeat sections…

AFIK Dorico 4.2 behaves the same as 3.5 regarding repeats.
Post the project and we’ll try to work out what is happening.

Err… Playback options and playback techniques are two different things. Have you even bothered to click on the link I sent you? And I have the feeling you’re not using Dorico pro…
Send your project and we’ll be able to make the adjustments for you.

Here’s my project…
Flows from Schubert Compositions Originales - Full score.dorico (4.0 MB)

Here’s my project:
Flows from Schubert Compositions Originales - Full score.dorico (661.3 KB)

Curious. When I open your project in either D3.5 or D4.2 the play repeats option is disabled. Yet, at a quick glance, I can see no problem with your repeat structures.

If I enable play repeats. All repeats work.

I re-saved your file with repeats working
Flows from Schubert Compositions Originales - Full score (1)-x.dorico (658.0 KB)

(@dspreadbury any idea how this could occur?)

1 Like

It works! Can you tell me how you solved this? And how could it happen?
Thank you for your time.

Since I have Dorico Pro, I was able to reset the Play Repeats setting, which is preserved when I saved the file.

As to how the problem happened in the first place - I have no idea… hence my query to the developers.

1 Like

If you hit play at any time the repeat structure was invalid, Dorico will have disabled repeats.

Which seems a bit extreme if, at the time the file is saved, the repeat structure is valid!
(it’s OK for Pro users who can reset it, but not for others)

I think having to reset it manually is still rather a pain even for Pro users.

Dorico disables the Play repeats option when you open a project that has an invalid repeat structure, not when you play back. However, I agree that this is annoying, particularly if you are using a variant of Dorico that doesn’t include the Playback Options dialog.

2 Likes