Reporting more sync errors....

Just did a quick test with Alan (thanks Alan)

latest version: - win10

Couldn’t get reliable sync win audio only (no midi)

Set ASIO buffers to max on both ends (1024)
Chat latency auto
set Delay to 5 seconds
set video and audio streams to lowest bit rate both ways
basically every setting to try to prioritise sync

Recording would start ok then after a few seconds the BLUE buffer would start to empty and then it would lose sync. Video was still running fine throughout and there was no loss of network connectivity.

So unusable.

I don’t really understand what conditions mean you don’t get sync and why it seems rather hit and miss ?

Missed this thread, sorry. Hard to keep up.
Delay 5 seconds is too much but shouldn’t harm. Everything else looks ok.
Did sync recover? I mean, when you start transport play or record again, does it start over like you described? As said, working on improvements and if this persists I’d like to set up a test connection if that’s ok with you.


delay was set to 5 seconds to see it that would help - made no difference

yes - sync recovered when you stopped - then as soon as you hit record the buffer drained and sync disappeared.

This was just a test with user alanharvey - who couldn’t get connection on his LAN - thought it would be a good idea to see if it worked across the internet. Obviously connected ok but was basically unusable.

This sounds exactly like what I experienced a few days ago – “specifically when recording starts, sync is lost on the DAW (“Connect”) side, and the recording is of silence” – however, the next day, with the same setup, everyting worked fine with no sync issues at all, in fact I was amazed at how smoothly the session went. The only possible conclusion is that it was something to do with network connection quality at the time.

Bear in mind that there has probably never been a time in the history of the internet where there has been such a demand on bandwidth as now in the time of the pandemic!

@musicullum, can you confirm please the ports VST Connect/Performer uses? I see UDP 51111, 51112 and 51113 for VSTC and 51117 for Performer here, if this is the same everywhere perhaps we could set up QoS on our routers for these ports?

yes, remember that thread …not quite the same issue although the root cause may be the same - Also impossible to say “the only possible conclusion” (IMO) - hard to know if your lack of recording was a routing failure ? (you missed the talkback connection for example)

interestingly most ISP are only seeing a very modest increase in traffic, not nearly as much as you might imagine. Mostly much less than 5%. Most video streaming services have dropped their data rates just in case. Peak time traffic really isn’t much different. And VSTconnect really doesn’t need much bandwidth - try measuring it…you can do a session with a few hundred kb/s - Don’t think that’s a factor here.

QOS won’t help in this instance - in fact is likely to make the problem worse

If nothing changed at either terminal then … ??? I’m only referring to the sync issue.

Please explain … how could prioritizing QoS for the ports used be detrimental?

That’s a long and complicated reply - probably best you google