Request for Insert Audio Files box changes

I think the “Insert Audio Files” box workflow needs a little improvement in the montage.

It’s nice that you arrange the insert order of files when inserting multiple files at once, but there are some easy ways to improve this feature.

When you have more than a few files to arrange the order before they get inserted, it would be nice to see a number next to each file to help identify what position that file is in. I noticed that when you try to insert files of a different sample rate than the montage, you do get numbers by each file name along with the sample rate but if you insert files that are the same sample rate as the montage as you would normally do, you just see a list of files but no number as to what order they are in.

These file order numbers are very helpful to me and it would be great if the numbers always appeared when “Inserting Audio Files…” and not just when a sample rate change is needed.

It would be nice to have a keyboard shortcut for moving the files up and down in the order within the “Insert Audio Files” box. Manually dragging or using the up/down arrow is a slow down when trying to do fast work all day setting up montages. Ability to highlight and key command a file to move up or down would speed things up.

I also find it extremely difficult to drag in files from the Finder and have them be inserted at ZERO. I can get them close to zero, but it’s easy to overshoot zero (to the left) and then the files snap back and don’t load. I basically always end up inserting at a random spot on the timeline and them move them around as needed, can this be improved? Also, can the default space between files inserted on the same track just be zero? I know some work arounds have been discussed.

I’m also hoping that the bug that makes my shortcut not work for “Audio Montage Properties” is fixed in 8.5. In the “Audio Montage Properties” box, I have a shortcut assigned to make either 44.1k or 48k montage but the shortcut doesn’t work. I mentioned it before but no follow up about the problem. I’ll attach a screen shot of that too.


For the shortcut, I can not reproduce the problem if I use a proper shortcut.
Please try something like Cmd+Option+some letter.

Ok, montage properties shortcut is working with a proper shortcut.

PS, please consider the Insert Audio Files box changes. I think many would appreciate a number slot when inserting multiple files.

Yes I will consider it.

Thanks, the numbers indicating file order and shortcut to arrange would be a big time saver.

Also, is there an easy way to make inserted files default or snap to zero that I’m overlooking when they are dragged in?

Don’t you use this hint?

No, I have not seen that. How do you make it appear?

Anytime I drag the files near the start of the montage I get the ø symbol and the files bounce back and don’t get inserted. I always have to drag and drop them a little bit into the montage for it to work.

If you have those option checked, then moving the mouse (while dragging) slowly around the start of the montage, should show that indicator.

Thanks, I played around with it a bit and now I’m seeing it. I hadn’t noticed it before, or hadn’t been able to make it appear.