Request: option to turn on/off lyric extender lines?

Hi,

I’m currently working on a set of songs that include a ‘translation’ of the lyrics in IPA (International Phonetic Language). It would be useful to have an option to turn off (in this case) the lyric extender lines; since underscores might actually be misleading in IPA, it would be advantageous to have an option to omit them, perhaps on a lyrics line per lyrics line basis?

The work around is to not include ‘spaces’ between syllables to cover any syllables that are sung over more than one note, but doing that plus adjusting the alignment manually so the ipa aligns properly with the syllable would become extremely tedious.

Thanks!
BK
Item-0_and_Item-0_and_Item-0_and_com.bjango.istatmenus.sensors_and_com.bjango.istatmenus.network_and_Item-0-5.jpg

Are you aware that you can control this from Engraving options? I’m far from the computer, but I think it is Engraving options -> Lyrics -> ‘Minimum space for extension lines’ or something like that. Just enter a high number, and They won’t appear.
I agree that it might be useful with a ‘disable’ option, both in the global options, and on an individual basis.

Can’t you just move forward with the arrows instead of space, and that will force extender lines to not appear?

Unfortunately, as of yet, it’s not possible to have different settings for lyric lines and lyric translation lines; I’d want to keep hyphens and extenders for original text. I suppose my needs are extremely specific to providing an International Phonetic Alphabet “translation”, as they have different hyphenation marks between syllables (periods instead of hyphens) and I think turning off underscore extenders for syllables that span multiple notes would be the ideal solution.

Absolutely, but it messes up alignment between the original syllables and ‘translation’ syllables… Of course I could go and tweak every syllable where this occurs, but… first world problems, I know… :smiley: