Rerouting CC data to pitchbend

Is it possible to reroute incoming CC data to be recorded as pitchbend data?
The pitchbend on my keyboard is busted, so I had to disable it/filter it out.
But I do need pitchbend sometimes. How do I go about getting Cubase to record pitchbend data from another controller? (I realize the resolution of CC data is much lower, but it would still be helpful)

Once more and still a case for the input transformer.

One thing you might need to watch out for, though…
Pitchbend is bi-polar (but much fun when in a good mood :stuck_out_tongue: ), so that means that, when converted from a regular CC#, zero pitch bend will be in the middle of your (for example) mod wheel’s travel. So, unless your mod wheel has a centre notch, you’d probably find it very difficult to return to exactly zero pitch bend.
It would probably be better, then, to use two different controllers (or, at least, two separate Input Transformer presets), one for pitch up and the other for pitch down, so that pitch bend will be reliably at zero when your mod wheel is all the way down.

The two attached screenshots show how to set up CC#1 (mod wheel) to convert to pitch bend up, and pitch bend down, respectively.

If you have available, two physical sliders, you could load the 2nd preset into the 2nd module of the Input Transformer (and changing the Midi Controller No. in the upper section, accordingly :wink: ), then have both “up” and “down” available simultaneously, but from two different sliders.

Hi vic, thanks very much for your reply and the screenshots. I think this will be very helpful and I will try this. Also a great point about the trickiness of returning to zero. I only have one controller left to use for pitch-bend, so maybe I will have to use two modules and switch between them depending on which way I need to bend, although it is a bit cumbersome. I have never used the input transformer, and I did search for an answer to my question on the board, but did not find the right one. So looks like I will be learning something new. :slight_smile:

Hm, unfortunately the approach outlined by vic did not work. I set up it up exactly like the screen shots (I tried both separately), so that CC #1 should be transformed to pitch-bend. Then I turn on the Module. However, nothing happens when I move the modwheel, i.e. the pitch does not change. Without the input transformer, if I use the modwheel, it does change the modulation of my VST instruments, so the input is there, but it seems it is not directed to pitch-bend for some reason despite the input transformer. Am I miss something?

You must be :wink: ('cos it definitely works here).
(and when the module is switched on, you get no “regular” modulation either?)
Can you post your screenshot, please?

Did you switch the Function mode to “Transform” (at the bottom of the window)?

Yes, the function mode is on Transform.

When the module is off, I get ‘regular’ modulation. When I switch on the module I do not get modulation, so it does seem to intercept the signal, but it does not result in pitch-bending.

I am attaching a screenshot of what I have:

Compare it with my screenshot again :wink:
In your bottom line, you have the Action target as “Value 1”… it should be “Value 2”.

Ah, how did I miss that. Thanks. However, there is still no change to the pitch after I change it to Value 2. Hmmm…

This is not normal :open_mouth: (they both work perfectly here).
I don’t normally do this, but I attach a zip file, containing both presets. Copy them into the appropriate folder (you don’t say whether you are on PC or Mac)…
On PC that would be “\Users<user name>\AppData\Roaming\Steinberg\Cubase 6\Presets\Input Transformer”
and on Mac, “/Preferences/Cubase 6/Presets/Input Transformer”
CC#1> (1.78 KB)
If it still doesn’t work, then the problem is elsewhere, (but I haven’t a clue what that could possibly be!)

Just to be certain than everything else is ruled out…
You are certain that the instrument preset in question does respond to pitch bend anyways (i.e.without the Input Transformer)?.. if your controller doesn’t even work well enough to try it, you can still write some pitch bend in the Key Editor :wink:, see if your Instrument responds to it.
You could also try (using the Input Transformer) recording some MIDI, and see what actually got recorded (in the Key or List Editor).

Hi vic,

thanks a lot for the presets. Even with those, it does not work. :frowning: I am on a PC. The instrument does respond to pitch-bend if I draw it into the pitch-bend controller lane. It just seems like it does not transform the CC data into pitch-bend data. And it seems like it must be something in Cubase that is preventing that. Because the CC data does come in, since I can control modulation with it - and when I draw into the pitch-bend, it does affect the pitch. So the problem must be in converting / transforming the CC data to pitch-bend. But what the problem could be, I have no clue either.

Anyway, thanks for your extraordinary help! I guess for now I will just draw in pitch-data when I need it, until I get a new keyboard…

Just for the info, please try recording your mod wheel, via the Input Transformer preset, and see what, if anything, has been recorded (e.g. in the List Editor). You could even post a (zipped) .cpr of that, and I’ll check it here.

Hi vic,

sorry I have been away - but I found out two things:

It turns out that the instruments I have been using to test the input transformer do not respond well to pitchbend - d’oh! So when I tried it with Halion Sonic, I successfully recorded pitchbend data with the modwheel through the input transformer, and on playback, Halion Sonic responded to the pitchbend data! So that is the good news - but: I cannot hear the pitchbending WHILE playing or recording. Only when I play back something I recorded does it respond to the pitchbend data. Is there a way to also hear it while playing/recording?

I attached a test.cpr using Halion Sonic: (55.9 KB)

Well, here, when I open your .cpr, the Input Transformer is empty! If I load one of the two presets that I posted, it then works. So, I have no idea how you even managed to record the pitch bend in the first place! :open_mouth: :smiley:

That’s weird, when I open it here, clicking on the “Input Transformer” button of the midi track on the left, then select “Global” (which is checked), the Input Transformer opens, and while it does not show that the Pitchbend Down preset is selected in the dropdown on top, the top and bottom parts of the Input Transformer contain the parameters of the Pitchbend Down preset, and the module is turned on. Maybe we used different names for the presets? Also, I use Cubase 6.5.5., not sure if that matters.

But so when you load the preset you can also hear the pitch-bend while playing/recording, not just while playing back the recorded track?

Must have been just a fluke… I reloaded your cpr, and the Input Transformer setting are indeed present now… and it works here, while playing/recording.

You don’t have the incoming controller filtered out, in Preferences>MIDI>MIDI Filter>Thru, do you?

Wow, you’re good!
I did have it filtered out, because the broken pitchbend on my keyboard once in a while sent data even though I didn’t touch it and caused instruments to go out of tune. I guess I can’t do that if I want to hear the pitchbend via input transformer…
Well, now it’s all cleared up. Thanks for all your help vic! Much appreciated! Hope I can return the favor some day…

In fact, I have just learned something new from this! :slight_smile:
I had no idea that the MIDI Filters worked post the Input Transformer! (and I’m really surprised that they do… but I have just checked it here, and that is indeed the case :wink: )

That is odd, huh. Since the filtering is a preference in Cubase, you would think it would filter everything out first before processing anything. Go figure…

Hi there!
A bit late I believe but I am in kindof the same situation but with some other gear, and vic_france, you seem to be the guru of the Input Transformer.
I am using a Theremini that can send pitch on cc20 and volume on cc97. Im trying to use the Transformer in Cubase 7 to trigger my synth with these cc`s. That means I also have to send a “note on” msg when the volume is above 0. Is this possible to work out?

I hope someone out there are able to help me out.