[Resolved] 5.5 and VE Pro

Hi all, finally did the update to 5.5 and was very happy to see it fix a lot of VST preset and stability crashes (often deep into a project after many many saves) that were happening in 5.1 that should never have been happening, even with Steinberg plugs like Groove Agent.

I was in the process of converting over projects from 5.1 to 5.5 when I noticed (in a new blank project) that Vienna Ensemble Pro is not seeing any of my slave machines . . . I rebooted my switch a few times and all my computers in the right order (which normally fixes this), but to no avail. 5.1 sees the machines in the connect window, but 5.5 does not.

VE Pro has always worked liked a charm in N4, N5, N5.1 . . . so I was surprised to see this. I’m running VE Pro v4.0.6150 build date July 2, 2010. I realize there are probably newer updates out there, but I hate to update things when they were working just fine, but I reckon this is the next step to try.

I also have a wonky network switch (too many DWP power surge hits) that needs to be replaced, but 5.1.1 works so its very odd.

Anyone else getting VE Pro to work in 5.5? If yes, would appreciate to know what version of VE Pro you are running.

I’m on a PC network, 7 / 64 on the master, with Vista 64, 32 and XP as slaves. Usually this is not an issue with VE Pro, which I’ve always found to be rock solid.

Seems its not just me, possible link to C6 code change implemented in 5.5?

http://www.steinberg.net/forum/viewtopic.php?f=19&t=11810

Can anyone at Steinberg please check this? Starting to smell like a bug to me.

Just wanted to update that today I did the following to rule out user error and problems with my configuration.

A. I updated all my e-licenser control centers to latest version, and updated VE Pro to latest builds. All maintenance tests on E Licensers were fine.

B. Then I pulled out the wonky network switch and replaced it with a brand spankin new one that I had in reserve.

VE Pro sees the slaves in N 5.1.1 64 Bit Windows 7 64 Ultimate.

It does not see the slaves in N 5.5 64 Bit, Windows 7 64 Ultimate.

I will be filing a support ticket with Steinberg, and reporting my issue over on the Vienna forum, but I’m calling this one a bug. If anyone can get theirs to work and show me I’m wrong with a setting to tweak, I’d be grateful.

Nuendo v5.5.0 on master machine - PC i7 - Windows 7 - with VE PRO Server 4.1.8008

Slave 1 - Windows Vista - VE Pro Server 4.1.8008
Slave 2 - Windows XP - VE Pro Server 4.1.8008

No problems - slaves appear in “available instances” window, and connect correctly.

Thanks for the info Andy, I’m glad I was wrong.

Not a BUG it seems, maybe a mite, definitely bizarre.

Whatever it is, I have been able to resolve this odd episode. For those who don’t want a long read, in short if you are having this problem you probably need to re-assign /refresh the IP address to the network card that your VE Pro network is running on.

My master machine, generally speaking, never touches the internet (only when I have to do a NI update or something like authorize N5.5). The slaves and the master run on an internal LAN that is run through a gigabit switch and cat 6 cables, the IP addresses are assigned through a separate older cat 5 cable which goes to the router. This is the scenario where 5.1.1 was able to see the slaves, but 5.5 was not. The IP addresses that showed up in 5.1.1 were the music lan addresses.

One of the slaves doubles as my office desktop and has a separate network card goes directly to the router so I can access the internet. This machine then has two cat 6 cables - one going to the switch to serve as a VE Pro slave and another going to the router to internet.

On a hunch I took a cat 6 cable and plugged in my “only when needed” internet designated port on the back of my Master and ran it to the router. The switch was still as is.

When I opened 5.1.1 this time I not only saw the right addresses for the local machines, but I saw an additional address for the IP address for the slave that was connected to directly to the router (i.e. the internet). VE Pro was finding both network cards on the dual purpose slave unit. That made me raise an eyebrow.

I opened 5.5 and then an instance of VE Pro. In the server window, I saw one connected address: The internet IP address of the slave machine. The switch IP addresses were still missing. Aha.

This told me that somehow the music network on my master machine was confused, so I ran a Windows networking diagnostic tool on the designated music LAN network adapter in the master machine. It reported back that it was not getting an IP address.

I don’t pretend to know how VE Pro or C/N platform works together at the networking code level, but it was almost like N5.1.1 remembered the local IP addresses and since 5.5 had never gotten a new lease, there was nothing for it to see. That’s my layman’s attempt at explaining it. The solution is to refresh the IP address (re-assign) on the network card of your Master that you are using for your LAN. This seems obvious now in retrospect, but if VE Pro is seeing the IP addresses in one version of software but not in another, its easy to miss.

So I unplugged the internet connections from the two machines. Unplugged the cable from the switch to the router and from the switch to the Master. Unplugged the router to the DSL modem.

Then I connected the router back to the DSL modem. Then the switch to the Master, then I plugged the router to the switch (which in turn would distribute to all the other computers connected, including my master). Then I connected the internet back on my dual slave box - i.e. router to the back of that computer.

Restarted the systems.

Opened 5.1.1 - VE Pro sees the 3 local addresses of the slaves.
Opened 5.5 - VE Pro sees the 3 local addresses of the slaves.
Internet works as normal in the dual purpose box, but running on it’s own network card directly to the router, Music LAN remains off internet as designed.

If this happens to you, you might need to power cycle your router, switch, etc. too. I was able to leave mine on.

I’ll update Vienna and my ticket.