[RESOLVED] Cubase Pro 10.5 crashes everytime EW Play 6.1.8 loads

Hi there,

Right after I updated PLAY to 6.1.8 (from 6.1.7), it stopped working with Cubase Pro 10.5.

Old saved projects that use PLAY already won’t open, will force Cubase to abruptly shut down while trying to load the mixer.

By using the Ctrl+Shift+Alt shortcut that disables all 3rd party plugins, I am able to open the project, then if I remove PLAY from the VST Rack, restart the DAW and select the same project, it will open with no issues at all.

If I open a new project that doesn’t have PLAY loaded (or an old project that doesn’t have it) and I try to load it, I get the well-known error “A serious problem has occurred… blah blah” It prompts me to a crash dump file, I have attached one of the many I had tonight while trying to solve this issue.

If I ignore that window and try again, for a second time, to load PLAY, it loads! I can work and save the project but if I close down Cubase and try open again the same project, it shuts down abruptly again.

I have tried some troubleshooting as well.

  • I rescanned all the plugins
  • I reinstalled PLAY 6.1.8
  • I ensured the eLicenser is updated and in good status
  • I ensured my iLok software is updated and in good status

PLAY is my main library for composing and unfortunately has a big impact on me not be able to use it right now. I do understand this is a Steinberg forum, however I believe there is presence from Eastwest within this forum (so it will help not jumping threads and forums), plus there is a Cubase crash dump file available, so please if you could look into it and help out it would be great! :smiley:

I will also raise a case on Eastwest’s website.

Please let me know if you need any further information from my end :slight_smile:

Cubase 64bit 2020.4.18 (1.68 MB)


The crash is obviously and completely on EW Play side:

00000000`0012db60 00007ff9`36f24d28 : 00000000`0012dbe0 00000000`00000000 00000000`0012dbe0 ffffffff`fffffffe : Play+0x4a7db5
00000000`0012db68 00000000`0012dbe0 : 00000000`00000000 00000000`0012dbe0 ffffffff`fffffffe 00007ff9`36f14c40 : Play+0x2c54d28
00000000`0012db70 00000000`00000000 : 00000000`0012dbe0 ffffffff`fffffffe 00007ff9`36f14c40 00007ff9`36f14c40 : 0x12dbe0

Hi Martin, thank you so much for looking into this!

Could you please let me know how you opened the .dmp file so I can investigate myself next time? Tried notepad but didn’t work.

Also to give you all an update in case you come across the same situation, indeed it was a Play issue and EastWest resolved it for me by providing the below instructions:


1.) Go to C:/Program Data to find where the “East West” engine folder is. You will need to delete this entire folder.

NOTE: The Program Data folder is hidden by default, so you will need to click on the ‘View’ tab and select “Show hidden files & folders.”

2.) Next, you will need to locate the Plug-Ins folder, look for play_VST_x64.dll and delete the file. It is located in C:\Program Files\VST Plugins

3.) Delete any files on your computer that include the play plug-in name (play.dll or play vst) in locations you’ve copied the Play plug-in, which includes any DAWS.

These files will usually be in the VST Plug-Ins Folder (C:/Program Files/VST Plugins) or anything on your computer that has the name “VST” in it.

VST3 - C:\programfiles\commonfiles\VST3 - Another location of these files.

4.) After deleting all of the VST files, please empty your recycle bin as well.

5.) Next, you will need to reinstall Play on your computer.

6.) Next, open the Installation Center. If you do not have the Installation Center already installed, see here -

7.) Sign in with your soundsonline account information and click the 3 gray lines on the right hand side of the program. Click the one that says “Library Directories”

8.) Set the directory for your Play libraries by hitting “Add”, and then navigating to where you have installed your Play libraries on your computer. Once this location has been added in the list, hit the “Default” button to make that the location where your libraries are added.

9.) Finally Restart your computer.

10.) Test Play in both standalone mode and within your DAW - Cubase 10.5.

Hi there, Ive got the same problem to, only I run it on a MacBook Pro , can anyone help me?