[resolved] Kontakt playback issue

I tried exchanging an existing VST Instrument for the included Hewitt Jones score.
So I went to the Playback mode, added Kontakt (see DoricoVSTSelection picture attached),
loaded the preferred Instrument on the left voice section (see DoricoVoiceSection pct. att.),
and pressed Play. All seemed to be ok, however then I wondered why both instruments sound identical.

I went to Halion Sonic SE right-click selected ‘Remove Program’ from channel 5 ‘Yamaha S90ES Piano’ to be sure only the Kontakt instrument was left, and surprisingly the piano part went silent….
Now I had a look at the mixer to verify why, and found the Kontakt Player using KT. aux 4 for output, (see DoricoMixer pct. att. on the very right handside) instead of what was selected in the DoricoVoiceSection stating Port 1, Channel 5.

Does anyone know what’s wrong and can help me resolve this issue ?



DoricoVSTSelection.JPG

It‘s getting weird. Creating a new score from scratch will actually use the Kontakt VST instrument and playback fine.

Removing all VST Instruments in the converted Dorico2 score and reentering VST intruments and channels, now lists Violin on channel 1 as HSSE Main Violin ?!? instead of HSSE 1 Violin before. There was no HSSE Main before. Even more strange all other voices are not muted, but are silent as well.

Something seems to be wrong with Dorico converting scores from a previous release and the mixes assigning randomly wrong instruments.

Any idea?

To get back to a known good state, choose Play > Playback Template to reset to the HSSE+HSO default, and make changes from there. This also ensures that expression maps are set correctly for the loaded instruments and that each is routed to a separate output in HALion. If you just load HSSE in the rack then it doesn’t get set up in that state.

Thanks Paul. This resolves the Interim issue, but sets it back to my initial problem with Kontakt being routed in the Mixer to Aux4, with no sound output for this instrument. Is there anything you could do to investigate the issue ?

Can you change the routing within the Kontakt mixer? Dorico has no way of knowing how a plugin routes MIDI events to each of its outputs, so currently it just assumes that MIDI channel is output to audio channel 1.

Kontakt might have some more options. I‘m just using the Kontakt Player, which is a stripped down version of Kontakt.
I set Midi Input and Output in Kontakt Player, and it behaves correctly when using Cubase Pro 10, Standalone, or when creating new scores in Dorico.
The issue seems to come when importing converted Dorico scores from earlier releases. Do you think it would help to send you the .dorico score for you to identify any glitches?

Yes, please do. p dot walmsley at steinberg dot de

The solution was not only to set Kontakt and the Native Instruments VST Instrument with the Port: (e.g. 1) and Channel: (e.g. 5) in Dorico3’s Playback menu, but to manually set the correct Port and Channel (to 5 in my case) in Kontakt Player as well. So I had to set the channel to 5 matching the entry in Dorico3 and I could hear the voice of the Kontakt instrument. Thanks for your help, Paul!