Resolved - No playback since 2.2.10 update

Since installing the 2.2.10 update, playback stopped working.

Halion Sonic SE loads correctly, and I get sound when clicking on the keyboard.

But when I press the space bar (or click the play button), the green playback wiper doesn’t move, the spinning beachball appears, and I have to Force Quit.

Also, clicking on existing notes in the score does not produce sound.

I tried:

  1. Restarting Dorico.

  2. Restarting the computer.

  3. Restarting my audio interface and its software.

  4. Quitting Dorico, trashing VST Audio Engine 2 preferences folder, re-launching Dorico.

  5. Creating a new project with just piano.

Same result each time.

“Device setup” looks fine.


Strange, very strange…
Though I have little hope that it may help, but please go to Device Setup and switch to a different sample rate, wait 3 seconds and then switch back.
When you then press play, does it work?
If not, please choose from the main menu ‘Help > Create Diagnostic Report’. That will create a zip file on your desktop, please send to ‘u dot stoermer at steinberg dot de’.


I previously posted here that it was working. However, that’s not correct.

I later discoverd that Dorico Elements had inadvertently launched instead of Dorico Pro. So when playback worked, it was in Dorico Elements.

I quit Elements and re-launched. This time, Dorico Pro started up.

One thing has changed: now when I press play, the green playback wiper moves. But still there’s no sound.

As before, I get sound from Halion SE by clicking on the keyboard.

I also tried switching to playback through the Mac Pro’s internal speakers, and got the same results.

I emailed you the Diagnostics File, Ulf. Thanks!

Thanks for the data, but there is nothing that immediately catches my eye.

Interesting point is, you can play on the on-screen keyboard and sound comes out, so the audio engine as such is working fine.
Now even the “green wiper” is moving but it seems that Dorico is not sending MIDI to the the audio engine, so this suggests that something in the Endpoint Setup got wrong.
If you go to Play Mode and select ‘Play > Playback Template’, that shall reload HSSE and also reassign the endpoints.
Does then sound come out?
Also, when you enable the Metronome (right to the Play button), does that make noise during playback?

One other interesting point you mention: You say that sometimes Elements launches instead of Pro. Is that really true?
What license do you have? Elements or Pro or even both? When a Steinberg software launches it usually checks for licenses from top down,
i.e. checks if a license for the “expensive” version is there and if that’s not available for the lower versions.

I launched Dorico just now (the computer had been asleep since last night), and playback worked without issue.

It had retained the setting from last night, using the Mac Pro’s internal speakers. I switched to the Metric Halo interface, and playback worked there as well.

In other words, the problem went away.

I forgot to mention this previously, but I tried enabling the metronome last night. It did not produce sound during playback.

Regarding Dorico Elements:

When playback started working last night, I wanted to check Playback Options, and pressed shift-command-P. Nothing happened.

At first I thought it might be an issue with my keyboard, but then I noticed there was no “Engrave” tab. I checked “About Dorico” and found that Dorico Elements had launched.

I’ve never installed Elements - I assumed it’s a sub-set of Pro, included in the Pro installer.

I’ve attached a screen grab of the error message “Failed to send GetInfo command”. I had to hit “OK” several times, and I think the window didn’t go away until after Dorico completed startup.

I also got a USB licenser error during one other launch last night. I don’t recall exactly what it was - maybe it didn’t see the licenser. This happens intermittently. I unplugged the licenser from the USB hub and plugged it back in.

One more data point:

I quit Dorico and then opened it a while later.

The problem re-appeared. Toggling the sample rate (per your directions) didn’t help.

But when I set the playback template to “Silence”, hit “Apply”, and then switched back to HSSE+HSO (Pro), playback worked.

Thanks, Ulf!

For the past couple of days I’ve been getting these ‘Failed to sen GetInfo command’ and Elements opening (at least buffering to open). I only have DPro2 installed, so in these cases I can’t edit or work with my symphonic works at all.

Also getting USB licenser problems. I’m glad I’m not the only one but is there a solution to this?

As bobk surmised, Elements is a subset of Pro, or rather, there is only one Dorico 2 application: it runs as either Pro or Elements dependent on which license is present. Have you tried running the eLicenser Control Center and letting it run its Maintenance Tasks?

Same thing happens after Maintenance. Only difference is that Dorico asked me to use a different USB port for the dongle upon startup.

It sounds like your problems are entirely due to the USB-eLicenser, and not specifically Dorico, which I know is cold comfort, but it suggests that if you can resolve those issues Dorico will run reliably for you. Make sure the USB-eLicenser is connected directly to a USB port on your computer, not via a hub. If you must use a hub, make sure it’s powered. If your USB-eLicenser is many years old, consider buying a replacement and transferring your licenses onto the new one. If you’re running Windows, try running eLicenser Control Center as administrator and running its default maintenance tasks again.

Does it make a difference that my Dorico Pro 2 license sits on my Soft-eLicenser? Only Cubase and some VSL licenses are on the actual USB-eLicenser and both load perfectly.

Are you definitely running the most recent version of Dorico, version 2.2.10?