RESOLVED: Piano staves too close in imported Music XML file

The attached screen grab show piano staves from a Piano part of a Dorico Pro 3 file created from an imported Music XML file.

There are no staff collisions in the Score, but all the piano parts are like this.

Is there a way to fix this without dragging each staff manually (which would be a major hassle due to the number of staves)?

I tried selecting all the staff handless and then “Engrave > Staff Spacing > Reset Layout”, but nothing changed.

I searched the web and the forums without success.

Thanks!
Staff_spacing_Dorico_Pro_3.jpg

Hi bobk!
You should not mess manually with those things. I would suggest to simply import this flow to a new project (open a new project, import flow -> that one) and Dorico will apply its defaults, which are usually near perfect.
Or you can select all and apply Edit>Reset appearance, which should give the same kind of result.
Check that in your import preferences, you do keep only things that really matter…

It looks like your vertical spacing—Ideal Gaps settings might be amiss. Are some of those values set to 0?

I wish I didn’t have to!

I tried both of these, and neither worked.

Not zero, but close - 1.9 mm.

How do I fix that?

SOLVED!

Dan, your post got me thinking about the staff spacing settings, and that led me to this:

In Layout Options > Staves and Systems > Casting Off, the box for “Fixed number of systems per frame” was checked, and the number of systems was set to 10.

I un-checked that, and the problem went away. Distance between treble and bass staves automatically changed to 10.5 mm.

EDIT: I don’t know how that box got checked, but I certainly didn’t do it! :smiley:

Great! Thanks for the feedback :slight_smile:

Bob, if you previously clicked ‘Save as Default’ in another project in which you previously had set fixed casting-off to specify 10 systems per frame, that would explain it. Those ‘Save as Default’ buttons are powerful but must be used with care.

Thanks, Daniel!

I don’t recall ever setting casting-off.

I did the following tests just now, and they seem to point to an issue with the specific MusicXML file (created with Sibelius Ultimate in March of this year):

  1. Opened two files created from scratch in Dorico Pro 2 (i.e., not from MusicXML import). The casting-off checkox was un-checked.

I’m 99 percent certain I did not click ‘Save as Default’ after un-checking it this morning.

  1. Opened another MusicXML file created on the same date as the one in question (also from Sibelius Ultimate). The casting-off checkbox was un-checked.

  2. Re-opened the MusicXML file in question. The casting-off checkbox WAS checked.

  3. Created new file in Dorico Pro 3. Checkbox was not checked.

Is casting off part of the MusicXML spec? (I did a quick search and found nothing about this.)

No, the setting is not part of the MusicXML file. If you start a new project and look in the Layout Options dialog, you’ll find that it’s set because at some point you’ve saved those settings as a default.

Just updated my previous post to include one additional test: I created a new file in Dorico Pro 3, and the box was un-checked.

Well, that’s probably to the good, since at least for a full score, having that value fixed for all projects is unlikely to be a helpful default.