Resource (?) issue with Nuendo 5+6 (PC): Can't open plugins

(Crossposting this to the N6 forum because it affects both versions – mods, please remove one if that’s not appropriate)

I’ve recently migrated my Nuendo machine from an old-ish Mac Pro to an i7 running Windows 7 Professional, and I’ve run into a real head-scratcher of a problem that occurs uniformly across 64bit and 32bit versions of Nuendo 5.5, 5.5.5 and 6.05.

Very soon after opening my first projects on the new PC, I noticed that Nuendo often flat-out refused to add more plug-ins (Effects or Instruments) to an open project; every plugin that I tried to insert into a slot just disappeared instantly without any kind of message. There appeared to be some kind of invisible wall to how many different plugins I can have in use (I could happily add as many instances of a single plugin as I wanted). For instance, with an empty project I could insert a Zebra and a Reverence instance, then – bam! – no more plugins. Or a UAD plugin, another (different) one – bam!, no more plugins, UAD or otherwise.

After a lot of fiddling about, I discovered that my SmartAV Tango controller seemed to have something to do with the issue. Tango needs some 95 device modules loaded into Nuendo, and I realized that I could trade these modules for more plugins and vice versa. :open_mouth: That is to say, when I remove a few of the Tango modules, I can open more VST plugins, but then Nuendo won’t let me re-add those modules (again, just silently ignoring the attempt) until I remove some VST plugins first.

To make a long story short(ish), I’ve taken a closer look at the Nuendo5/6.exe process with Process Explorer, and I discovered that there seems to be a hard limit to how many threads it can have running at any time: 256. It starts out with around 50 threads, then every new plugin typically adds 1 or 2 threads, and as soon as the number gets close to 256, Nuendo refuses to add any more plugins. Now, each of the Tango device modules adds 2 or sometimes 3 threads – which explains why I can’t do much of anything at all when all Tango modules are loaded, because then the thread count will already be at ~240 even with an empty project.

I’ve done a cross-check with all Tango modules removed (and uninstalled from my system so Nuendo won’t even see them); when I just add different plugins to an empty project, the described behavior occurs at around the 130 plug-in mark. So the issue doesn’t have anything to do with the Tango stuff per se, it just happens to exhaust the thread limit much more quickly (I’m sure I’d never have run into the issue otherwise, as I don’t tend to have 130 different plugins in a single project).

Sorry for the lengthy post… I’m stumped on this. Can someone with a Tango (or someone with enough plugins and patience to replicate my “one-of-every-kind” test described above) confirm that I’m not dreaming this up? Steinberg, any hints? For the record, I’ve been using the Nuendo/Tango combination for years on my Mac without any problems.

Here’s my configuration: Intel Core i7 3970X @ 6x4GHz, Intel X79 Pro, 32 GB RAM, Windows 7 Professional SP1, Tango 1, NetSmart Win7-x64. Tested with Nuendo 5.5 (32bit), Nuendo 5.5.5 (64bit), Nuendo 6.0.5 (64bit).

I had - and unfortunately have - this problem often - at least if I understand your issue correctly.

It is (in my opinion) an issue with the VST Bitbridge.

When I open a project which was created in Nuendo 32bit in 64 bit and I have a lot of 32bit plugins in it it will hang while loading. In the same time it can happen that you “max out” the amount of 32 bit plugins during the mix and then you can not insert another one (of these).

2 years ago as I was working on a 400 track mix I went 64bit and had to spend some time fiddling around which plugins are fine with the bitbridge and which one do better when bridged via jBridge.

I ended up bridgning all UAD plugins and all those freeware oldscool VST2 plugins from “back those days” - while Drumagog for example was not running fine via jBridge, this plugin I use via Nuendo bitbrige.

Well, it is a PITA that there are still so many issues… Slateplugins confirmed that Trigger is still 32bit, though they have an 64bit installer… ?! Because I asked why I can not load that plugin in larger sessions (sessions using RAM more than 3GB or something)… It seems that the installer installs someting in the 64bit folder which is still 32bit and which is bridged by the host applications bitbridge automatically…

Today I tried to open a project in 64bit which was running fine yesterday - it hang up while loading. 32bit Nuendo opens whithout a problem, so does Nuendo 6. Nuendo 5.5.6 does not.

I removed ONE instance of drumagog - now there was just one single 32bit plugins left (a reverb) - I was able to open it. In the same time I am working on some Blind Guardian style mix, 400 tracks and zillions of plugins - for example 8 Drumagog and 3 of these 32bit Verbs… No problem!! I do not understand …

Try only to use true 64bit plugins. Does it now work? As I said - I have the feeling the Steinberg Bitbridge is only capable to run a certain amount of plugins… Roughly I would say 20 or 30 - but the issue today was differnt, just a few 32 bit plugins and I was not able to open anymore…