Resource (?) issue with Nuendo 5+6 (PC): Can't open plugins

(Crossposting this to the N5 forum because it affects both versions – mods, please remove one if that’s not appropriate)

I’ve recently migrated my Nuendo machine from an old-ish Mac Pro to an i7 running Windows 7 Professional, and I’ve run into a real head-scratcher of a problem that occurs uniformly across 64bit and 32bit versions of Nuendo 5.5, 5.5.5 and 6.05.

Very soon after opening my first projects on the new PC, I noticed that Nuendo often flat-out refused to add more plug-ins (Effects or Instruments) to an open project; every plugin that I tried to insert into a slot just disappeared instantly without any kind of message. There appeared to be some kind of invisible wall to how many different plugins I can have in use (I could happily add as many instances of a single plugin as I wanted). For instance, with an empty project I could insert a Zebra and a Reverence instance, then – bam! – no more plugins. Or a UAD plugin, another (different) one – bam!, no more plugins, UAD or otherwise.

After a lot of fiddling about, I discovered that my SmartAV Tango controller seemed to have something to do with the issue. Tango needs some 95 device modules loaded into Nuendo, and I realized that I could trade these modules for more plugins and vice versa. :open_mouth: That is to say, when I remove a few of the Tango modules, I can open more VST plugins, but then Nuendo won’t let me re-add those modules (again, just silently ignoring the attempt) until I remove some VST plugins first.

To make a long story short(ish), I’ve taken a closer look at the Nuendo5/6.exe process with Process Explorer, and I discovered that there seems to be a hard limit to how many threads it can have running at any time: 256. It starts out with around 50 threads, then every new plugin typically adds 1 or 2 threads, and as soon as the number gets close to 256, Nuendo refuses to add any more plugins. Now, each of the Tango device modules adds 2 or sometimes 3 threads – which explains why I can’t do much of anything at all when all Tango modules are loaded, because then the thread count will already be at ~240 even with an empty project.

I’ve done a cross-check with all Tango modules removed (and uninstalled from my system so Nuendo won’t even see them); when I just add different plugins to an empty project, the described behavior occurs at around the 130 plug-in mark. So the issue doesn’t have anything to do with the Tango stuff per se, it just happens to exhaust the thread limit much more quickly (I’m sure I’d never have run into the issue otherwise, as I don’t tend to have 130 different plugins in a single project).

Sorry for the lengthy post… I’m stumped on this. Can someone with a Tango (or someone with enough plugins and patience to replicate my “one-of-every-kind” test described above) confirm that I’m not dreaming this up? Steinberg, any hints? For the record, I’ve been using the Nuendo/Tango combination for years on my Mac without any problems.

Here’s my configuration: Intel Core i7 3970X @ 6x4GHz, Intel X79 Pro, 32 GB RAM, Windows 7 Professional SP1, Tango 1, NetSmart Win7-x64. Tested with Nuendo 5.5 (32bit), Nuendo 5.5.5 (64bit), Nuendo 6.0.5 (64bit).

I just had this happen to me last night.

Working on a few projects that were started in Nu5.55, then migrated to Nu6.05
These weren’t giant projects…not even close.

Suddenly I couldn’t add any plugins. When I tried, nothing would happen.
Then I noticed that the ones that were already loaded started opening
with blank interfaces…When I tried to “save the project as” it wouldn’t even
let me change the project name and nothing would happen when I hit the save button…Sometimes the save window wouldn’t even open.

Sounds and seems like a memory issue.
All during the trial with Nu6 I never experienced this and
I put it through some heavy tests.
Now, just days after purchasing the upgrade, I get this nonsense.
Looks like it’s back to 5.5 for me.
The only time I ever experienced anything like this in Nu5
was when the machine was pushed to its absolute limit.
This was not the case last night.

Windows 7 32bit
Gigabyte MB
i7 3770k
12gb (Yea, 8gb just sitting there, waiting)
UAD-2 PCIe (x) 2
RME PCI (Digi 9652)
Nu 6.05
Nu 5.55
Nu 2.33
Nu 1