Resource use during export vs during editing

There’s something very strange in Cubase and Nuendo that I can’t find any reason for and nothing online on it. This was happening in Cubase Pro 13, and since yesterday when I bought Nuendo 13 and loaded the project, it’s exactly the same thing.

Basically I see a substantial difference in the way virtual instruments are assigned resources during editing as opposed to during export. Here’s what I mean.

For the last few months I’ve been working on and off on a MIDI mockup that is a beast, for a song that has lots of ostinatos with really fast violins and violas, and sometimes even cellos. In addition, it has a lot of percussion with snares, taikos and other things.

I don’t want to make this too long, but basically I threw the kitchen sink at it, with a lot of different instruments, most of which take up a lot of RAM. It’s a learning project, so I’m having fun with it, testing what libraries get closer to the original and so on.

Because the project is insanely heavy, it takes about three minutes to load, but in projects with 70+ tracks, just because it loaded and you see all the tracks and the mixer, doesn’t mean it’s ready for playback. Because the project may be loaded, but each and every instance of the SINE, Opus, Kontakt and all the other engines you use need to load each library that you have in there, so that takes a while. If you load the Berlin Strings in SINE, and you see that loading bar on the right that shows you the progress, and takes a few seconds, well, imagine that multiplied by 40 times, plus all the Opus instruments, then Kontakt and so on.

This means that if I want to play all the instrument tracks, I have to wait a few minutes or it will start to hiccup often, with the ASIO guard getting into the red constantly. This happens especially when there are violin runs in several tracks, and most of those tracks have the SINE player.

Sometimes, it’s been 45 minutes since I opened the session, and I still get hiccups with those runs or parts of the song where there are too many tracks with MIDI notes at the same time.

My machine is a Mac Studio M1 Ultra with 64 GB of RAM and a 4 TB internal drive that benchmarks as high as 7 GBps, and still this project is heavy for a machine that is insanely fast for everything else. But I’m not complaining, I know it’s a very heavy project for any machine, and I don’t think it would be any different in Logic or any other DAW.

But here’s where it gets interesting and the reason why I want to ask people if they are experiencing the same. All this happens while I’m editing the project. However, when I export the project to either a single file, or even more demanding, to 70+ audio tracks to create a new project, it seems to engage in turbo mode and exports the whole thing in a little over 2 minutes (the song is about 8 minutes long). The resulting file is perfect, no digital glitches of any kind. The audio tracks for each instrument, also flawless.

You might say that it’s because I had already loaded the song a while ago, so everything was loaded into RAM and that’s why it didn’t glitch and exported so fast. I thought the same. Until I did a simple test.

I rebooted the machine, loaded Cubase and chose this project from the window it shows with the list of projects. After waiting the three minutes for it to load, during which it shows the progress of each instrument loading, but you don’t see the project window or the mixer, as soon as I saw those two appear, I pressed the key command for export, and exported to a single file the stereo out bus. That exported in the same two or so minutes, and the audio file was perfect from start to finish.

Then I did the same process as before (rebooting, etc) but exported all the instrument tracks to a new project. Also, flawless.

All this was in Cubase. Yesterday I got Nuendo, so I thought I would see how this project behaves in it. Turns out exactly the same. During editing, it’s useless for a few minutes after finishing loading, unless you solo a few tracks and just listen to those, and even then, it depends on how many.

But, if you export to either a single file, or all the tracks to a new project, it’s like Clark Kent goes into Superman mode. 2 minutes to render an 8 minute project
flawlessly. Hell, I even set Nuendo to the background while I was typing an email. Other times I did the same but went to some website. And this one takes the cake. I switched to DaVinci Resolve and made some video previews while Cubase was rendering in the background, and it didn’t take any longer!

So this puzzles me. Clearly, my machine can handle the demand, otherwise, it could never render an 8 minute song in 2 minutes, it would take much longer, and at times I would see the progress bar stall for a while.

So what is it that Cubase/Nuendo does different when exporting compared to when you’re just editing the project? Here’s a screenshot of my settings in case you see something wrong:

I didn’t take a screenshot of the buffer, but I always keep it at 1024. But recently I set it to 2048 to test this, and it didn’t make a bit of a difference. And these settings you see here, I tried different variations of them without much success. Everything you see there I disabled, enabled, different combinations, nothing worked.