"Respell Using Note Name Above" not working with german keyboard

language german - keyboard layout german, key commands set to ALT-ß
(this assignment is ok, because I get # with Umschalt-ß and b with ß - I would not like to change it
and assign other keys to this function).
ALT-ß works, changes eg. A to Gx - but ALT-Umschalten-ß does not work (nothing happens, but should result on A in Bbb).

(did not work with 1.1, not changed with 1.2)

Some keys on the German (and some other European language) keyboards are “dead keys” that produce accents for combining with other characters. You cannot assign key commands to combinations that correspond to dead keys, I’m afraid.

I use a German keyboard, and the key that writes ß also writes ? when used with the shift key, and \ when used with the right hand ALT key. In this respect it is like 7 8 9 0, which are to the left of it. They produce / ( ) = in conjunction with shift (umschalten) and { [ ] } in conjunction with RH-ALT (Alt Gr).

So I cannot see what dead keys, like the one that produces acute and grave accents, have to do with it.

David

OK, I will grab our German keyboard and look at it again later on.

Daniel, when you play around with the German keyboard, perhaps you could also check the shortcut for the concertina drag up (Alt + K). Doesn’t work for me either. Alt + J works as expected.

Something new in this case?
It’s really a problem, because one needs respelling terribly often.

As in the english keyboard layout neutral-flat-sharp is mapped to “0” “-” “=”
it won’t work alike with a german keyboard, because “=” -> gets “`”, a key that only works as “decorator” for accented vowels.

As “-” gets “ß”, which works fine for “flat”, the smalles adaptive change possible is to give “sharp” to Shift-ß (that yields ?), that also works.

Now, respelling is conceptually very near to setting the accidental; it’s logical and straightforward to map this function to
Alt-ß and Alt-Shift-ß (or written alternatively: thats Alt-?).
Alt-ß works, Alt-Shift-ß definitively not.

Btw. AltGr on the key yields the blackslash. Could this be the problem? But Alt and AltGr are different keys!?

This should be fixed, quick respelling is really important (sometimes I still hit Enter, because I used it so often in Sibelius…)

Hi taguluche,

also bei mir liegt die enharmonische Umdeutung schon immer auf Alt+ß und Shift+Alt+ß und das funktioniert einwandfrei, zumindest auf MacOS.

Liebe Grüße,
Jochen

well, its Win10 here…

I’m on Win 10 as well.

In the meantime, you should assign another key command, since the default ones don’t work.

Daniel, the strange thing is, that “Using Note Name Above” is assigned to (Alt + Umschalt + ß), but it doesn’t work. Reassigning the same shortcut doesn’t work either. So I chose my own one. Could you please confirm, that is a problem on Dorico’s side and not a problem with my computer?
I also wanted to assign the concertina drag (Alt + K) to another shortcut, but I couldn’t find the place to do this. Could you please tell me, where I can find the correct position in the German version?

I can’t easily confirm anything without access to a German keyboard, which I won’t have until January, but I daresay the problem is on Dorico’s side, particularly given that a few of you are having the problem.

You can’t edit the Alt+K shortcut directly in the Key Commands page of Preferences. You could edit the JSON file by hand, by adding lines to the kEngraveMode context in a text editor, but use a text editor that has proper syntax colouring/checking for JSON files (or paste the whole JSON file into jsonlint.com after editing it) to check that you haven’t broken the syntax.

					{
						"EventEdit.Nudge?Direction=Up&Amount=kALittle&AlternateNudgeMode=true": [ "Alt+K" ]
					},
					{
						"EventEdit.Nudge?Direction=Down&Amount=kALittle&AlternateNudgeMode=true": [ "Alt+J" ]
					},
					{
						"EventEdit.Nudge?Direction=Right&Amount=kALittle&AlternateNudgeMode=true": [ "Alt+L" ]
					},
					{
						"EventEdit.Nudge?Direction=Left&Amount=kALittle&AlternateNudgeMode=true": [ "Alt+H" ]
					},
					{
						"EventEdit.Nudge?Direction=Up&Amount=kALot&AlternateNudgeMode=true": [ "Ctrl+Alt+K" ]
					},
					{
						"EventEdit.Nudge?Direction=Down&Amount=kALot&AlternateNudgeMode=true": [ "Ctrl+Alt+J" ]
					},
					{
						"EventEdit.Nudge?Direction=Right&Amount=kALot&AlternateNudgeMode=true": [ "Ctrl+Alt+L" ]
					},
					{
						"EventEdit.Nudge?Direction=Left&Amount=kALot&AlternateNudgeMode=true": [ "Ctrl+Alt+H" ]
					},

I’m not sure, if I dare to edit the JSON file. :slight_smile: I will have a look after Christmas.

I’Ve just discovered another missing shortcut on the German keyboard (WIN 10):
You can change to the next layout using Alt + Shift + + in setup mode and engrave mode, but it doesn’t work in write mode. The shortcut for the previous layout works in all three modes (Alt + Shift + Ü).

Hi Daniel,
I was waiting for the update to see, if you have corrected these missing shortcuts. Unfortunately there have been no changes.
Now I have checked the keycommands_de.json file and found out, that all the missing shortcuts are in there and seem to be correctly assigned. At least jsonlint.com valdiated everything as correct. So I still think, that there is something going wrong here …

We’ll look into this some more and try to figure out what might be wrong.

Thanks!

Daniel,

I’ve just tested the missing german shortcuts in Dorcio 2:
“Respell Using Note Name Above” now works in Win 10 on my German keyboard.
Also Alt + Shift + + (see above) now works in all modes.

Thanks!

Only Alt + K (Concertina drag) still doesn’t work. Alt + K is also assigned to the Skript Menu, which opens, when I press alt + K in “Notenzeilenspationierung”. Can I delete the shortcut for the script menu somewhere? This is something I don’t use at all.

I’ll see about getting this mnemonic removed from the Skript menu in the German version in a future update, Heiko.