RestoreRig Crashing Issue

RestoreRig seems to be the culprit, making WE9.5 crash when trying to play a track. Does anyone else have RestoreRig instabilities, or any pointers to where I might try to fix this.
Thanks.

I was just about to say it worked fine at 44.1 with all modules on, and all controls at 12 o’clock, but then I went to remove RestoreRig from the Master Section and when I removed it, I got the serious error in the picture. I’m on Win 10 too. No other plugins in chain.

What sample rate and RR modules and settings are you using?

Also, when I had it up, I noticed the de-Buzzer 0% sensitivity is not really 0%. With level setting at even -0.5db and sensitivity at 0% on a loud song, there is audio audible in noise listening mode.
RestoreRig Serious Error.PNG

Hi,

Sample rate 44.1
Just trying to use Debuzzer - level -48, sensitivity 0, gain 0dB

I’ve tried re-installing without success.

You could enable crash reporting and submit a crash report.
https://www.steinberg.net/forums/viewtopic.php?t=122528

Yes, the same problem I am having!

No crash here under windows 10. Anyone got a precise step-by-step procedure that produces a crash every time?

Yes, I think this should crash on any system. It crashes on two systems here. Whether 9.5.25 Elements or Pro. All latest Win 10 updates and all latest Wavelab 9.5.25 Elements and Pro:

  1. Open a 44.1 wav file from the desktop (or wherever).
  2. Load Restore Rig in the first slot in the Master Section.
  3. Make sure all 3 modules in Restore Rig are enabled. Settings don’t matter I don’t think. I’ve tried all at 7 o’clock and 12 o’clock with same result.
  4. Play the WAV file.
  5. Click the left speaker button to hear what’s being removed, even if nothing. Click again to close the speaker.
  6. Click the middle speaker button to hear what’s being removed, even if nothing. Click again to close.
  7. Click the right speaker button to hear what’s being removed, even if nothing. Click again to close.
  8. Stop play.
  9. Close Restore Rig with the upper right “X” button.
  10. Right click the Restore Rig plugin in the Master Section to remove it.

If you get what I get (and I’m getting this every time using this procedure) you’ll then either get the “serious error” message, or Wavelab will just hang unresponsive, and you’ll eventually get a spinning ball, and a message from Microsoft that it needs to close Wavelab and report it to Microsoft.

Thanks for the accurate report. I can reproduce.

Thanks PG.

Just to confirm, it crashes here too with that step-by-step.

We need to get an update to correct this issue. I’m wasting time and money. It’s really frustrating.

The first time I tried this with the new Elements 9.5.30 update, removing the Restore Rig plugin as before, I got no crash, whereas I got it every time with the previous version. The second and third time I tried it with 9.5.30 and did more module tweaking and playing the audio file, auditioning etc. I got the crash again when trying to remove the plugin.

I had enabled Wavelab crash reporting before doing any of this, but I don’t get a crash dialog from Wavelab, only from Windows.

Using Windows 10 latest.
Wavelab Elements 9.5.30 with Restore Rig.PNG

Yes. Still doing it. I downloaded WL 9 to see if it worked. Worked fine. So its definitely the WL 9.5 with Windows 10 not working even after the latest update. I’ll be waiting for a fix. At least now I can work with version 9 for now.

Have had the same restore rig crash issue since installing WL 9.5. Was advised by Steinberg to reinstall Cubase 9.5 and WL 9.5 but it has not changed anything. Cubase 9.5 will not export to Wl 9.5 either. I am running on Windows 7 and since WL 9 worked fine on it I shall have to go back to it as well. Steinberg told me that they were not able to repeat the crashes in restore rig so I am glad that someone has set them straight that there is a problem.

I am having the same RestoreRig problem her on my Win10, even with the latest WaveLab Elements Version 9.5.40.
All other PlugIns are working fine. My DAW with Cubase Pro10 is working fine as well.

Any ideas to solve this annoying problem?

Still happening on my elements 10 install. So pissed. Just as all have said . Come on WTF

Still happening on my elements 10 install. So pissed. Just as all have said . Come on WTF

I am having the same problem with Wavelab 10 on Windows 10, i can’t believe this is still a problem.

Still having the same issue as well, even after an upgrade to Wavelab pro 10.

It seems to happen on old AMD CPUs, that don’t support the modern instruction set.

1 Like