rests in cross staff bars

I have read all the posts about this and the option to “show bar rests in additional voices” option in setup - notation options does not help because I only want the rests from the bass clef to appear in the upper staff part (it’s piano with two bass clef saves at this point). Is there a way to do this or some other option for cross staff beaming that doesn’t use the cross staff menu? The screenshots show what I am able to achieve but I don’t want a whole bar rest in the upper staff.
Screen Shot 2019-04-08 at 10.35.01.png
Screen Shot 2019-04-08 at 10.34.34.png

A. Cross-staff beaming can be achieved using the M and N keys - you don’t need to use the beaming.
B. By default, you shouldn’t get a whole note rest - Dorico automatically hides it as long as you’re using the primary voice (which is normally but necessarily Upstem Voice 1 or Downstem Voice 1). Turn on View > Note and Rest Colors > Voice Colors and see what’s going on.

Thank you pianoleo. I’ve tried all those options but I’m still not able to get the appropriate rests to appear in the top staff. Changing the upper beamed notes to another voice doesn’t solve the problem either. It’s treating all the notes as part of the lower staff’s voice obviously. Switching the alternate chords to a different voice undoes the cross staff beaming. I’ll have to try another workaround.

Screen Shot 2019-04-08 at 12.28.28.png

Copying my answer from your Facebook post: You can add explicit rests manually in the upper staff. Note Input Mode, Rest Mode, Force Duration. Then hide the ones you don’t want to appear.

Alternatively there is an option to add bar rests in the bar line panel if I’m not mistaken.

How could I show the automatically hidden whole rest? I did it already in other works.
Currently, I do not remember how I did it.

Shift-b, rest in the popover

2 Likes

Thanks!