Rests in pickup bar/instrument change in first full bar

There is a pickup in percussion in the opening measure and the trumpets go immediately to vocal on the first full measure. I want my staff name to say trumpet, not vocal, but if the rests are in the measure, the staff name defaults to “Vocal.” As a workaround, I put notes in the trumpet part and then used “custom scale” to make then disappear. However, this eliminates the rest at the beginning. What I’m trying to achieve is the staff name trumpet, rests in the pickup bar and then vocal in the first full measure.
This is what it looks like with my “workaround”


This is what it looks like if I start with the rests in the trumpet part (note vocal designation on staff name)
Screen Shot 2023-06-29 at 11.09.45 AM

You can show the Players name for the trumpets and not the Instruments name.

Layout Options > Staffs and Systems > Staff Labels > Show players name instead of instruments name

Just make sure the players name are correct.

edit

if you want the name (Trumpet in Bb) only appear once, name the players “1”, “2” and “3” and add a staff text to the second trumpet and move it to the correct spot.

For each trumpet in galley view, restore the rest in the pickup bar, select that rest and execute Write>Create Chord Symbol Region. Then switch to page view:

Image

Note that the chord symbol regions do not print.

2 Likes

John, that worked great! Thanks for the help!

Thanks for the help!