Retrologue 2 download problems, am I alone?

Hi poeple,
First post with a problem!! So, been using Logic for ages and just took advantages to Steiny’s update to old LE versions to LE9. Which made me buy the update to Elements 9. All in all pretty impressed with the app considering it’s the entry-level stuff for Cubase. Sleek interface and the feature set suits me well apart from the lack of arpeggiator.

So, I bought Retrologue 2. In fact, downloaded the trial without success as the demo license was there in the eLC but there is no installation of .vst3 component in the Library’s VST3 folder from the download. So, nothing to be found in C9. Opened Logic and it fails the validation with “fatal error-1”. So, VST and AU doesn’t work!!!

I’m not reading any problems anywhere on the web so I wonder what went wrong. When I bought the plugin, I received the activation code, downloaded it in the eLC so I see my Retrologue 2 in the SeL and the trial license also. I contacted support and will see what they’ll say but I’m a bit lost. If anybody have any idea, that would be great. Thanks for your time.


The download link for it can be found by logging into your Steinberg Shop account, but the email with your activation code should also have a link for it.

Try completely removing Retrologue 2 and then reinstalling it again using this installer. It should appear under the Synth category of your VST instrument list.

Personally I think you should have spent another $99 and just upgraded to Cubase Artist 9, which comes with Retrologue and Padshop for free along with a ton of other stuff, on top of being a far more complete DAW. If you bought it this month you would get a free upgrade to Cubase Artist 9.5, saving $50. I think you can still get a refund for Retrologue 2 if you feel like upgrading Cubase instead.

Thanks for the reply. Yeah I thought about going the Artist route but I don’t want another dongle and buying Retro alone gives me a AU version I can use in Logic. That is if I get help from Steiny someday. 3 days later and still no news.

I have the chance of working somewhere where we have a demo station with CP9 so for now I copied the Retrologue component in the VST3 plugin folder and all its assets elsewhere in the system. It’s working since I have a code in my SeL but it’s not helping the AU side of things.

What I find odd is when I did this: before what was inside the Steinberg folder in the VST3 folder was another folder named Retrologue.vst3. When I droped the copied component inside the Steinberg folder, the Retrologue.vst3 folder morphed into the regular component icon/image. So, it’s like if the component was there before but was not recognized as a plugin but as a simple folder by the system. Never seen this happened in my 20 years of working with Mac. But then again I never cracked anything and always use the legit installers so I never have to “repair” anything over there.


Well update… I just rescaned Retro2 in Logic and it validated!!! Crashed Logic the first time I opened it but now it’s working. The AU component seems to be only a shell or something as the vst weight in at 97MB and the AU a mere 800KB. Anyway, I’m happy.

@Romantique TP, man you put this spark of Artist in my mind and I’m not sure anymore if my decision was good… :wink: