Retrologue is running with a 2+ seconds delay . not usable

Hi,
I recently bought cubase artist 13 and all seem to work fine but at some point I can’t run retrologue anymore. It delays with seconds. I tried to reinstall it and also rescan my mediabay. Nothing helps. Any suggestions? Is this a known issue?
Im running Cubase 13 artist 13.0.30 and retrologue 2.4.0.
My system:
i7 11th gen.
16mb mem
1 tb ssd
win 11 pro

TIA
Johan

Hello and welcome to the forums,

what you refer as delay is called latency. Latency is created by any of these two sources:

  • ASIO driver
  • plugins

The ASIO driver has a buffer settings (in samples), this latency is steady, ie. it does not change unless you change the buffer size.
So I would guess that the “all of a sudden” added latency stems from one or more plugins. Each plugin has their own specific latency value. For many it is so small that it is neglectable. Others, like the StereoImager, induce quite a high latency as they need some time for processing.

In Cubase’s MixConsole you can display any latency value from plugins in the project:

Unfortunately this does not solve my problem. I checked the ASIO drivers and I’m using Yamaha Steinberg USB ASIO (512 samples). I also checked the plugins but no additional plugins added. I Created a new project and added 1 instrument (Retrologue). I also tested another instrument I use (Vital). It immedately becomes almost unresponsive for both instruments. Also checked the Latency Overview ion the MixConsole. There seem to be none.

BTW thanks for the quick response (I appreciate that)

I have never heard of any case where a VSTi latency was not caused by driver and/or plugin latency.
The plugin latency gets induced also when plugins are loaded in places that are not part of the signal path. Please make sure you did not overlook any plugin anywhere.
Also check if you have a plugin installed that is running in trial or demo mode. It might create this latency on purpose.

Is this reproduceable when you start a new session, and you only add Retrologue?

Yes that is exactly one of the scenarios I described previously.

Again thanks for your quick reactions

Johan

Ah, sorry to hear that…I hope you find the solution soon…

I tested the Retrologue and Groove Agent. They are both not responsive and unusable at this point. Urgently need help

Try moving (or renaming) your preferences folder. (Cubase can not be running when you do this.) Start a new Blank project and add a VST instrument.

If that doesn’t do it, I would try running LatencyMon.

I think I solved it. I believe that @Johnny_Moneto was correct. I removed all third party plugins, created a new project with only a retrologue instrument and it was performing again, no latency problems. Now I only install Vital because i realy like that one. Lets see if that works.
FYI: I removed Vital, Valhalla Supermassive, Tal Filter 2 and wave arts tube saturator.

Thx all for your help

1 Like

remember there is the constrain plugin delay compensation button: Constrain Delay Compensation , this turns off all of the FX that are adding computational latency, so you can play live easily even in complex projects.