Retrospective MIDI Record Greyed Out

Hey y’all, so I just laid down a long MIDI track without apparently pressing the Record button. I go to Transport, but Retrospective MIDI Record is greyed out…it’s checked in my preferences, and I have a rather large buffer set for it, so what’s the deal?

Hi,

If you want to use the Retrospective Record, you have to have a MIDI or an Instrument track in the project. The Record Enable button has to be enabled first. Only in this case is the MIDI data passing thru to Cubase, and you can catch them afterwards by using Retrospective record.

To clarify you don’t need to have a Track Write Enabled while you are playing (but you can). However in order for the Retrospectively recorded data to get inserted onto the Track then you need to have a Track Record Enabled - which tells Cubase which Track to put the data on.

Hi,

But if none of the track is Record Enabled, then you don’t get any data to the Retrospective Recorder. Or am I wrong?

No, you do. I just did that a few days ago. I think it must always be saving a buffer of whatever MIDI is coming in. I’ll play around with it a bit when I’m at Cubase.

Ha, Raino, you’re right. Only for printing the midi to the track is a record-enabled midi track needed. Just tried it with no tracks in the project at all. Kind of cool, and seriously on point for the feature.