Retrospective MIDI record issue

When using retrospective record the DAW produces multiples for each note, and long ghost notes that were not played. Using the “delete doubles” in the MIDI editor doesn’t do anything either.

This happens even though the MIDI input set to ONE source (NOT “any”).


Is it the same when you record in real time?

Could you just for the rest disable all other MIDI ports in the Studio > MIDI Ports Setup, please?