Retrospective Record Not Capturing Expression Maps

This happens in both Cubase 8.5 and 9.

  1. Create a blank Session

  2. Create an expression map with at least three articulations

  3. Hit record, change the articulation play a note, press stop = this works

  4. Hit play, change the articulation play a note, hit stop, hit retro record = this works

5) hit play, change the articulation play a note, hit retro record, then hit stop = no expression map recorded

  1. hit play, change the articulation, play a note, change to another articulation, play another note, hit retro record, hit stop = this works

So number 5 doesn’t work and it is very easy to replicate in both 8.5 and 9.

Please please fix this as it is very frustrating.

Please post an image of the exp map. Include its entire window.

Here it is.
Screen Shot 2017-05-05 at 10.36.40 AM.png

I tried triggering the expression map with program change instead of key switches and got the same exact results.

I’ve also tried triggering the expression maps with different input sources. i.e. different midi controllers and still the same exact results described above in both CB 8.5 and 9.

Hm. I can’t reproduce, but I’m on PC. I wonder though if the exp maps idea is just a red herring. Can you repro this without the map on the track?

Hi SteveInChicago,

I’m pretty sure it’s only related to expression maps as the actual notes and CC data still gets recorded. Although if you can confirm this works on a PC that would be great, as maybe we can get another Mac user to confirm it does not work on Mac.

I’m currently running OS X 10.10.5

Also when testing please be careful with the order of operations I’ve laid out as it is very important when you press the space bar and when you press retro-record.

I’ve also tried enabling and disabling the preference “Snap MIDI Parts to Bars” under the “Record - Midi” preference pane. Unfortunately that didn’t fix it either.


I can replicate this as well on 10.12.6 and Cubase 9.5.3