Retrospective record not working with 2nd keyboard

Hi
I’ve found that retrospective record does not work when I am using a second keyboard to, well, play the midi events that I can hear during playing. After hitting insert retrospective recording all that is created is an empty midi part.
Presumably Cubase is ignoring the data entered from the second keyboard for some reason.
If I do exactly the same thing with my other keyboard insert retrospective recording works.

Very strange as I can see the midi events in the monitor during playback and of course I can hear them anyway also.
I don’t think there is any setting that would directly or indirectly make Cubase ignore midi input for the purposes of inserting it as a retropective recording, is there?
It does say if I hover over the icon “Insert retrospective recording from all midi inputs on selected track”.

Thanks
J

Hi…
I have only been having problems with retrospective recording since CB12…
I am wondering if you found an on/off switch somewhere. Cant get it to work at all.
It worked find in all of my other versions.