Retrospective Recording - Cubase 12 Pro

Does anyone else experience the notes all being jumbled when inserting a Retrospective Recording? It looks like the notes are being recorded on top of another recording?
(BTW: this also happens after I clear the RR buffer).

Not here, at least : using the Transport > MIDI Retrospective Recording > Insert from all MIDI inputs commands, i get a MIDI part in which both the notes timing and velocities are accurately rendered.

What is the value of your Preferences > Record > MIDI > MIDI Retrospective Record Buffer Size in Events setting ? I have set it at 10000 : no issue when I use RR with it.

@cubic13 thanks, but yeah, my setup is the same…buffer size set to 10000.
Velocities and note lengths are in there and accurate etc. …its just that the first 30 seconds seems to be recorded on top of an earlier recording - even after I clear the buffers.
Wonder if there was a hack where I could ‘separate’ the two recordings…

And what does it give you when you activate the Show lanes button in the track header ? Here, I always get two different lanes, if there was a previous MIDI part in the involved track : one with this part, and another with the RR render…

EDIT : Welcome, by the way… :slightly_smiling_face:

@cubic13 - Thanks for the welcome! I’ve been a Cubase user since the COmmodore 64 days, LOL, and very rarely use the forum, but tech support has been a bit flaky recently so here I am…

I tried the Lanes idea but nope, still get one big slab of jumbled up midi.
Just about to try increasing the buffer size beyond 10000…

Nope - increasing the buffer didn’t work either.
RR is a great feature, but I cant really use it at the moment due to the absolute mayhem it produces… Shame, not sure what I’m doing wrong here…

Do you have your track set to receive only a single MIDI channel? I would try that if not. I’ve had noisy Mod Wheels and an odd sticky key or pot sending random notes before.

Additionaly to what @SF_Green has suggested, could you also post a screenshot of an involved MIDI/instrument track showing an RR rendering with Show Lanes active ?

Hi cubic13, I’m just in the middle of a mixing project, but will get back and post the screenshot shortly. Thanks for your help.

Hi. I have the same issue. Sometimes if I try to RR a significant chunk of music (several minutes of piano noodling, say), the region seems to have two performances superimposed on top of each other. I think I may have seen a related issue, which is that when I hit RR, I don’t get everything I just played, but only some of it.

This is a new problem for me - it didn’t exist in SX3 up to C10. It seems to have appeared in C11.

I’m about to try upping the buffer to 100,000, which is the limit.

I feel like RR has been rewritten or something - another change (which is neither good nor bad really) is that if you hit shift-* multiple times, the newer versions of Cubase will duplicate the same region again and again.

Hi,
Same problem here. I have cubase 12 pro and i found The RR really buggy. Most of the time i experiment the superimposed recording, and other strange behaviors: several notes have their note off in the end of the recording so their length is exaggerated… sometimes it just don’t record…
I am using on a daily basis the RR of pianoteq and it is infinitely more reliable than RR cubase…

I had same problem, sounded like some midi loop, I was able to fix it by eliminating “all available” midi inputs and chose only the keyboard.