Reveal in Finder not working in Pool? Mac


I don’t think I’ve ever been able to get this to work correctly. It will open Finder but it doesn’t even try to go to the right folder. If I don’t have an instance of Finder open, it will open a new window on my home directory. This doesn’t seem to pass in a path at all.

Anyone else have this issue or find a fix for it? I’ve tried looking in settings everywhere in Mac and in Cubase

EDIT: It’s also worth noting files will open correctly if they’re not on an external drive, but anything on an external drive doesn’t open.


Do you try it with a sample from your sample library or with a file you have recorded to the project (or common regular WAV) file, please?

Some libraries are archived/packed. So if you try to reveal this type of fie, there is no path to the specific *.wav file, in fact. Therefore it doesn’t work.

Yes. I tried with several files. If the project is on my external drive then it doesn’t open the containing folder at all.

I have the same issue. So it’s related to using external drives?

That’s my guess… doesn’t seem to ever have a problem with external samples though

If anyone’s found a workaround I’d be glad to hear it

So this is a bug then. Is it properly reported?

I don’t believe so. If you know of a better way to report it besides the forum voting please let me know.

if anyone has a better solution than putting projects not on an external I’d love to hear

I moved my user profile back to the internal drive (for other reasons) and it’s still not working properly. It seems to me that if I stick a file in the Documents folder it does not work properly but if I put it in a random folder somewhere else on the drive it does work.


Sorry, I can’t reproduce it here, or I do something different than you. This is what I do:

  • Store any Audio (WAV) file to external drive.
  • Drag and Drop the Audio file to the project.
  • Make sure the Copy File to Project Folder option is disabled.
  • Open Pool and double-check, the file comes from external drive.
  • Right-click the file in the Pool and choose Reveal in Finder.

Find window with the file opens and the file is selected.

Am I missing something?

I’m on macOS 10.15.

@Martin.Jirsak The issue only happens to me when the project itself is saved on an external drive. If I move the project to my local drive there’s no problems and all files open in finder normally. Can you try starting a new project on an external drive and trying the same process you described?


Does it mean the project is on the external drive, same as the audio file, you want to Revel in Finder? Is the Audio File in the Audio subfolder of the project, please?

The project is on the external drive… it doesn’t matter if the external audio is on the same drive or not… it doesn’t open either way… I’ve tried audio from both sources and it doesn’t matter…

If the project is on an external drive, any audio file will not open in finder…
If the project is on the internal drive, it finds external or internal files in finder with no issues.

were you able to replicate with the above steps?

Did it work for you Martin?


Sorry, finally I found a time to work on this.

Unfortunately I can’t reproduce it. The project sits on the external drive and I can Revel in Finder. The Finder opens and point to the file.

I have tried to create project on the system drive, then back it up to the external drive. Then I have tried to Reveal in Finder from this backup project. It worked. Then I tried to record another track, which was already storing the audio file to the external drive. I tried Reveal in Finder. It worked. Then I quit Cubase, eject the external drive. Mount the drive again, start Cubase, open the backup up project, Revel in Finder both files, it worked.

Then I created a new project on the external drive from scratch and recorded an audio into it. Then Revel in Finder. Worked. Quit Cubase, unmount the drive, mount it back, start Cubase, open project, Revel in Finder, it worked.

I just can’t find a pattern, where it wouldn’t work to me.

The issue only occurs if the project root is on my external drive. I tried another external drive as well but had the same result. It’s as if the correct path isn’t being pass onto Finder. It opens Finder but then doesn’t go to the path…

An interesting note though… when I have a project on my external drive, it opens any existing Finder instances but doesn’t redirect to the correct path…
If I have the project on my internal drive, it opens a new instance of Finder with the correct path…It’s as if the external drive causes it to fail and then doesn’t bother opening a new instance of Finder


Can you see the correct path, if you scroll to the right, to the Path column, please?

Btw, how is your external drive formatted?

It’s formatted: Mac OS Extended (Journaled)
and the path shows something like this: