Reverence Pro license error launcing Cubase 10.5 or 10

Hi ,
i’ve just purchased Cubase 10.5 for mac os 10.14.6 with also a brand new usb elicenser. (just a day ago)
previously i’ve used cubase 10 with another elicenser (loaned) .

it is only when i tried launching Cubase 10.5 or 10 with the new elicenser, i get this error

i’ve also tried starting up both 10.5/10 with the loaned elicenser but that one does not produce any error with reverence pro .
i’ve tried removing the said reverence files from the content/vst sound folder but when i tried to launch cubase with the new elicenser it asks to locate the files which i eventually did , and it produced the same some content cannot be loaded error (Reverence Pro)

i’ve also ran maintenance on the elicenser app.

other than that i can work with no issues at all except for this nagging pop up whenever i launch cubase.

this is my new elicenser screenshot with the serial blurred

please advise on a possible solution,
much appreciate ! :frowning: