"Reverse" Latency when recording audio in Cubase


I have Cubase 7.0.7 on a Windows 7 PC with a Lexicon Omega USB-connected audio interface. I am satisfied with Cubase, of course, and with the sound quality of the Omega. When I record audio via a mic connected to the Omega Cubase places the sound on the audio track 20ms earlier than the correct placement.

I did the following two experiments:

  1. Record midi track with a shot, succinct hi hat sound.

  2. Mic the speaker connected to the Omega.

  3. Create audio track and record the hi hat sound from the speaker, through the mic and the Omega in Cubase 7.

  4. Visually compare the placement midi notes and the audio track. The audio is placed 20ms too early, i.e. visually to the left of the midi note.

  5. Create audio track in Cubase

  6. Play recorded audio track with hi hat sound and record the sound on the new audio track, from the speaker, through the mic and the Omega in Cubase 7.

  7. Visually compare the placement of the audio on the two audio tracks. The audio on the new track is placed 20ms too early, i.e. visually to the left of the audio on the existing audio track.

I have no clue what might cause this behavior. My workaround is for audio tracks to use track parameter where I can move the playback of the whole track back and forth in time. This kinda works but it is a hassle and I always have this feeling that things may be just a couple of ms out of sync.

Yes, I can try and upgrade to Cubase 8 but I wish to wait a while with doing that and there is no guarantee that it will work, right?

Any help will be greatly appreciated, thank you.


Hi there

I have collected data which may help diagnose my latency problem when recording audio.

My Lexicon Omega driver offers six diffent buffer sizes. I have measured the misplacement of the recorded data for each buffer size and I have found the “Record shift” value on the VST Audio System page which makes the recorded audio signal appear exactly in time with the playback audio.

ms Buf Record shift value
+8 5.6 +1425
+1 10 +100
-11 18.7 -500

  • 24 36.1 -920
    -58 70.9 -2570
    -108 140.6 -6000

WIth the present behaviour I will have to use a different Record Shift value according to the buffer size selected. In my understanding Cubase should be able to place the recorded audio signal exactly at the same time as the playback material. I am correct in my understanding? And if so, what may be the root cause behind the present, erratic behaviour?

Thanx in advance,


Record shift should not be necessary, CB should compensate for the latency (buffer size) you use. Are you using an ASIO driver for your sound card? And, apart from being visually shifted - is the audio really 20 ms late as audio?

BTW, a small shift would make sense due to electron travel time from audio card to speaker and mic to audio card - but more so due to acoustic travel time of the sound from speaker to mic, depending on the distance between the two…

Thank you very much for your reply. Here is some additional info based on your feedback:

  1. I use the Lexicon Omega ASIO driver and I have upgraded the driver to newest version I could find
  2. The sound I record travels from Cubase to the Lexicon via USB, and from one Lexicon analog output to one Lexicon anolog input via a cable. There is no mic involved.

Both auraly and visually the recorded sound is shifted from 108ms too early when the buffer size is 140.6 go 8ms late when the buffer size is 5.6. I plotted the Measurements in an Excel graph and it is not a linear function which surprised me.

Anyway, please share with me if you have any suggestions about how I can proceed from here.



I have the exact same problem but for me it occurs when recording MIDI. Never used to have this problem but somehow it just started be reversed latency for the MIDI notes. Tried upgrading to Cubase 8 but the issue still exists.

I’m still suspecting the Lexicon driver, but this may also depend on your OS… The driver should communicate the latency to Cubase and Cubase automatically adjusts recorded tracks accordingly. Are there other audio interfaces active (and maybe interfering) in your computer? Did you try Lexicon support?

So this may be a Lexicon driver issue and not a Cubase issue. I will contact whatever Lexicon forum available and see if they can help…or perhaps the time has come to invest in the UR44?


I used to have the midi be early, I think it was, hard to remember exactly but the solution for that and a lot of other timing problems was to find in the midi settings somewhere is a checkbox called USE SYSTEM TIMESTAMP
Check that and see if it helps.

Hey, I’m using a Scarlet 2i2 as the interface and facing the same problem. How can I prevent this “reverse delay”? My buffer time is set to 4ms and it shifts quite a lot to the left of the cursor.